aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorCarlos Sánchez de La Lama <csanchezdll@gmail.com>2017-01-04 23:52:41 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-04 23:57:30 +0100
commit4a6f099e2c6dc3115abe708ea500d9e96e2ec0dc (patch)
tree51b07df45cc07978774eec6fde0a715ad784d96f /gnu/packages/bootstrap.scm
parent440a3143f01083649dedddc97a0d6108bb3d2920 (diff)
downloadguix-4a6f099e2c6dc3115abe708ea500d9e96e2ec0dc.tar
guix-4a6f099e2c6dc3115abe708ea500d9e96e2ec0dc.tar.gz
gnu: bootstrap: Add the dynamic linker name for "powerpc-linux".
This commit completes cross-compilation support for powerpc-linux-gnu. * gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add "powerpc-linux" case.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index f6faba3188..64a82393af 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -168,6 +168,7 @@ successful, or false to signal an error."
((string=? system "i586-gnu") "/lib/ld.so.1")
((string=? system "i686-gnu") "/lib/ld.so.1")
((string=? system "aarch64-linux") "/lib/ld-linux-aarch64.so.1")
+ ((string=? system "powerpc-linux") "/lib/ld.so.1")
;; XXX: This one is used bare-bones, without a libc, so add a case
;; here just so we can keep going.