aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-07 00:42:18 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-07 00:42:18 +0100
commit1fb78cb2c36a6b0d7a3ecf1f7150c4d99b01c1a9 (patch)
tree1cbfbf62d46a8f9d3f20f19b68bcc194827d3c7d /gnu/packages/bootstrap.scm
parent6ba9dd813db7c528cb99e442a066bcf832f27330 (diff)
downloadguix-1fb78cb2c36a6b0d7a3ecf1f7150c4d99b01c1a9.tar
guix-1fb78cb2c36a6b0d7a3ecf1f7150c4d99b01c1a9.tar.gz
packages: Remove the default value for `license'.
* guix/packages.scm (<package>): Remove the default value for `license'. * gnu/packages/bootstrap.scm (package-from-tarball, %bootstrap-glibc, %bootstrap-gcc): Initialize `license'. * tests/packages.scm (dummy-package): Likewise.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 22ee98879a..ffe1ec6528 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -104,7 +104,8 @@ check whether everything is alright."
("tarball" ,(bootstrap-origin (source* (%current-system))))))
(synopsis description*)
(description #f)
- (home-page #f)))
+ (home-page #f)
+ (license #f)))
(define package-with-bootstrap-guile
(memoize
@@ -284,7 +285,8 @@ $out/bin/guile --version~%"
"08hv8i0axwnihrcgbz19x0a7s6zyv3yx38x8r29liwl8h82x9g88")))))))))
(synopsis "Bootstrap binaries and headers of the GNU C Library")
(description #f)
- (home-page #f)))
+ (home-page #f)
+ (license lgpl2.1+)))
(define %bootstrap-gcc
;; The initial GCC. Uses binaries from a tarball typically built by
@@ -351,7 +353,8 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
"06wqs0xxnpw3hn0xjb4c9cs0899p1xwkcysa2rvzhvpra0c5vsg2")))))))))
(synopsis "Bootstrap binaries of the GNU Compiler Collection")
(description #f)
- (home-page #f)))
+ (home-page #f)
+ (license gpl3+)))
(define %bootstrap-inputs
;; The initial, pre-built inputs. From now on, we can start building our