aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-02-08 00:36:12 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-02-08 07:18:35 -0800
commit0424d1fffddb85ec76fe3e2653c0753fe75f2c55 (patch)
tree5372c7865ab40ebad462f94695e37c6dfd2472eb /gnu/packages/bootloaders.scm
parent703e5c92eeb38d86455c2b1cace5cad9fc08b349 (diff)
downloadguix-0424d1fffddb85ec76fe3e2653c0753fe75f2c55.tar
guix-0424d1fffddb85ec76fe3e2653c0753fe75f2c55.tar.gz
gnu: u-boot: Update to 2021.01.
* gnu/packages/bootloaders (u-boot): Update to 2021.01. (u-boot-pinebook-pro-rk3399): Add patch-pinebook-pro-config phase.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 88abe29a1e..60556dc501 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -478,7 +478,7 @@ tree binary files. These are board description files used by Linux and BSD.")
(define u-boot
(package
(name "u-boot")
- (version "2020.10")
+ (version "2021.01")
(source (origin
(method url-fetch)
(uri (string-append
@@ -486,7 +486,7 @@ tree binary files. These are board description files used by Linux and BSD.")
"u-boot-" version ".tar.bz2"))
(sha256
(base32
- "08m6f1bh4pdcqbxf983qdb66ccd5vak5cbzc114yf3jwq2yinj0d"))))
+ "0m04glv9kn3bhs62sn675w60wkrl4m3a4hnbnnw67s3l198y21xl"))))
(native-inputs
`(("bc" ,bc)
("bison" ,bison)
@@ -927,6 +927,13 @@ to Novena upstream, does not load u-boot.img from the first partition.")
(substitute-keyword-arguments (package-arguments base)
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'unpack 'patch-pinebook-pro-config
+ ;; Fix regression in 2020.10 causing freezes on boot with USB boot enabled.
+ ;; See https://gitlab.manjaro.org/manjaro-arm/packages/core/uboot-rockpro64/-/issues/4
+ (lambda _
+ (substitute* "configs/pinebook-pro-rk3399_defconfig"
+ (("CONFIG_USE_PREBOOT=y") "CONFIG_USE_PREBOOT=n"))
+ #t))
(add-after 'unpack 'set-environment
(lambda* (#:key inputs #:allow-other-keys)
(setenv "BL31" (string-append (assoc-ref inputs "firmware")