aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-06 13:22:42 -0500
committerMark H Weaver <mhw@netris.org>2015-01-06 13:31:44 -0500
commit7cd802f342407c0d1cdef888a2e0d22f07690bb4 (patch)
tree6c5f02d1b668297a4fecad3348f89af2cd8b5e66 /gnu/packages/boost.scm
parentd2e842814a233b7d0a72b4071fa2e8878fe0bb82 (diff)
downloadguix-7cd802f342407c0d1cdef888a2e0d22f07690bb4.tar
guix-7cd802f342407c0d1cdef888a2e0d22f07690bb4.tar.gz
gnu: boost: Fix target-system check.
* gnu/packages/boost.scm (boost): Fix target-system check.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 3e8d2b8a02..1767681955 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,7 +53,7 @@
;; Boost's 'context' library is not yet supported on mips64, so
;; we disable it. The 'coroutine' library depends on 'context',
;; so we disable that too.
- ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+ ,@(if (string-prefix? "mips64" (or (%current-target-system)
(%current-system)))
'("--without-context" "--without-coroutine")
'()))))