aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-09 18:35:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-09 18:37:33 +0200
commitf895a7a4d41a37871b044e48984d460bc896db68 (patch)
tree08a66a8de25479bcfea39f3e5397090258810db7 /gnu/packages/bioinformatics.scm
parent22103f16f213e5938a07c11e16059715a0a66dd0 (diff)
downloadguix-f895a7a4d41a37871b044e48984d460bc896db68.tar
guix-f895a7a4d41a37871b044e48984d460bc896db68.tar.gz
gnu: trim-galore: Update to 0.4.5.
* gnu/packages/bioinformatics.scm (trim-galore): Update to 0.4.5. [source]: Fetch from git. [arguments]: Remove custom unpack phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 98149f2674..bba7056db2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11141,25 +11141,22 @@ with narrow binding events such as transcription factor ChIP-seq.")
(define-public trim-galore
(package
(name "trim-galore")
- (version "0.4.2")
+ (version "0.4.5")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://www.bioinformatics.babraham.ac.uk/"
- "projects/trim_galore/trim_galore_v"
- version ".zip"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FelixKrueger/TrimGalore.git")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0b9qdxi4521gsrjvbhgky8g7kry9b5nx3byzaxkgxz7p4k8bn1mn"))))
+ "0x5892l48c816pf00wmnz5vq0zq6170d3xc8zrxncd4jcz7h1p71"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
- ;; The archive contains plain files.
- (replace 'unpack
- (lambda* (#:key source #:allow-other-keys)
- (zero? (system* "unzip" source))))
(delete 'configure)
(delete 'build)
(add-after 'unpack 'hardcode-tool-references