aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-18 16:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-18 19:50:01 +0200
commit0e47fcced442d8e7c1b05184fdc1c14f10ed04ec (patch)
tree4ae844bc0ec3c670f8697bdc24362c122fa718ad /gnu/packages/bioinformatics.scm
parente4b70bc55a538569465bcedee19d1f2607308e65 (diff)
parent8b1bde7bb3936a64244824500ffe60f123704437 (diff)
downloadguix-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar
guix-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm112
1 files changed, 56 insertions, 56 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ab698fc0e8..b844fe5f63 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -71,7 +71,6 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages code)
- #:use-module (gnu packages commencement)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpio)
@@ -1120,62 +1119,63 @@ alignments and perform the following operations:
(license license:expat)))
(define-public bioperl-minimal
- (let* ((inputs `(("perl-module-build" ,perl-module-build)
- ("perl-data-stag" ,perl-data-stag)
- ("perl-libwww" ,perl-libwww)
- ("perl-uri" ,perl-uri)))
- (transitive-inputs
- (map (compose package-name cadr)
- (delete-duplicates
- (concatenate
- (map (compose package-transitive-target-inputs cadr) inputs))))))
- (package
- (name "bioperl-minimal")
- (version "1.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bioperl/bioperl-live")
- (commit (string-append "release-"
- (string-map (lambda (c)
- (if (char=? c #\.)
- #\- c)) version)))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0wl8yvzcls59pwwk6m8ahy87pwg6nnibzy5cldbvmcwg2x2w7783"))))
- (build-system perl-build-system)
- (arguments
+ (package
+ (name "bioperl-minimal")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bioperl/bioperl-live")
+ (commit (string-append "release-"
+ (string-map (lambda (c)
+ (if (char=? c #\.)
+ #\- c)) version)))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wl8yvzcls59pwwk6m8ahy87pwg6nnibzy5cldbvmcwg2x2w7783"))))
+ (build-system perl-build-system)
+ (arguments
+ (let ((transitive-inputs
+ (map (compose package-name cadr)
+ (delete-duplicates
+ (concatenate
+ (map (compose package-transitive-target-inputs cadr)
+ (package-inputs this-package)))))))
`(#:phases
(modify-phases %standard-phases
(add-after
- 'install 'wrap-programs
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure all executables in "bin" find the required Perl
- ;; modules at runtime. As the PERL5LIB variable contains also
- ;; the paths of native inputs, we pick the transitive target
- ;; inputs from %build-inputs.
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin/"))
- (path (string-join
- (cons (string-append out "/lib/perl5/site_perl")
- (map (lambda (name)
- (assoc-ref %build-inputs name))
- ',transitive-inputs))
- ":")))
- (for-each (lambda (file)
- (wrap-program file
- `("PERL5LIB" ":" prefix (,path))))
- (find-files bin "\\.pl$"))
- #t))))))
- (inputs inputs)
- (native-inputs
- `(("perl-test-most" ,perl-test-most)))
- (home-page "https://metacpan.org/release/BioPerl")
- (synopsis "Bioinformatics toolkit")
- (description
- "BioPerl is the product of a community effort to produce Perl code which
+ 'install 'wrap-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure all executables in "bin" find the required Perl
+ ;; modules at runtime. As the PERL5LIB variable contains also
+ ;; the paths of native inputs, we pick the transitive target
+ ;; inputs from %build-inputs.
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/"))
+ (path (string-join
+ (cons (string-append out "/lib/perl5/site_perl")
+ (map (lambda (name)
+ (assoc-ref %build-inputs name))
+ ',transitive-inputs))
+ ":")))
+ (for-each (lambda (file)
+ (wrap-program file
+ `("PERL5LIB" ":" prefix (,path))))
+ (find-files bin "\\.pl$"))
+ #t)))))))
+ (inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-data-stag" ,perl-data-stag)
+ ("perl-libwww" ,perl-libwww)
+ ("perl-uri" ,perl-uri)))
+ (native-inputs
+ `(("perl-test-most" ,perl-test-most)))
+ (home-page "https://metacpan.org/release/BioPerl")
+ (synopsis "Bioinformatics toolkit")
+ (description
+ "BioPerl is the product of a community effort to produce Perl code which
is useful in biology. Examples include Sequence objects, Alignment objects
and database searching objects. These objects not only do what they are
advertised to do in the documentation, but they also interact - Alignment
@@ -1183,7 +1183,7 @@ objects are made from the Sequence objects, Sequence objects have access to
Annotation and SeqFeature objects and databases, Blast objects can be
converted to Alignment objects, and so on. This means that the objects
provide a coordinated and extensible framework to do computational biology.")
- (license license:perl-license))))
+ (license license:perl-license)))
(define-public perl-bio-db-hts
(package
@@ -12941,7 +12941,7 @@ let before_space s =
("ocaml-batteries" ,(package-with-ocaml4.07 ocaml-batteries))
("ocaml-camlzip" ,(package-with-ocaml4.07 camlzip))
("ocaml-csv" ,(package-with-ocaml4.07 ocaml-csv))
- ("ocaml-sqlite3" ,ocaml4.07-sqlite3)
+ ("ocaml-sqlite3" ,(package-with-ocaml4.07 ocaml-sqlite3))
("ocaml-xmlm" ,(package-with-ocaml4.07 ocaml-xmlm))
("ocaml-mcl" ,(package-with-ocaml4.07 ocaml-mcl))
("ocaml-gsl" ,ocaml4.07-gsl-1)))