aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-06 19:12:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-06 19:13:35 +0100
commit0d9824cc127f045d32c22d0c75df46d97cb61624 (patch)
tree4332b2b127f0d4eefab9cc31e50020f6b9430b4b /gnu/packages/bioinformatics.scm
parent7bcfb590a6d25fb4f675f0ab5cf743d6454729a8 (diff)
downloadguix-0d9824cc127f045d32c22d0c75df46d97cb61624.tar
guix-0d9824cc127f045d32c22d0c75df46d97cb61624.tar.gz
gnu: bedtools: Update to 2.27.0.
* gnu/packages/bioinformatics.scm (bedtools): Update to 2.27.0. [arguments]: Remove custom "install" phase; specify prefix.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 12 insertions, 16 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f0b589b6c0..fedc8aec4c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -421,31 +421,27 @@ computational cluster.")
(define-public bedtools
(package
(name "bedtools")
- (version "2.26.0")
+ (version "2.27.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/arq5x/bedtools2/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/arq5x/bedtools2/releases/"
+ "download/v" version "/"
+ "bedtools-" version ".tar.gz"))
(sha256
(base32
- "0xvri5hnp2iim1cx6mcd5d9f102p5ql41x69rd6106x1c17pinqm"))))
+ "0q6fsiz4s52yzxs6h2vxwq95fsi3n64wkpinkk05mfh4dmhybw74"))))
(build-system gnu-build-system)
- (native-inputs `(("python" ,python-2)))
- (inputs `(("samtools" ,samtools)
- ("zlib" ,zlib)))
(arguments
'(#:test-target "test"
+ #:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
- (for-each (lambda (file)
- (install-file file bin))
- (find-files "bin" ".*")))
- #t)))))
+ (delete 'configure))))
+ (native-inputs `(("python" ,python-2)))
+ (inputs
+ `(("samtools" ,samtools)
+ ("zlib" ,zlib)))
(home-page "https://github.com/arq5x/bedtools2")
(synopsis "Tools for genome analysis and arithmetic")
(description