aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-16 16:09:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-16 16:09:54 +0200
commit2b4dcc477b0046e741bb0735a62370c05aaf9254 (patch)
tree45345d46d023be7afa9f9ce1fd08cc3ac9226882 /gnu/packages/bioinformatics.scm
parent872e17ddc1308e26c3e7216000f456196520e000 (diff)
downloadguix-2b4dcc477b0046e741bb0735a62370c05aaf9254.tar
guix-2b4dcc477b0046e741bb0735a62370c05aaf9254.tar.gz
gnu: Add go-github-com-biogo-graph.
* gnu/packages/bioinformatics.scm (go-github-com-biogo-graph): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 86c35f8177..5eefb2a807 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16429,3 +16429,28 @@ alignment algorithm. It completes MashMap with a high-performance alignment
module capable of computing base-level alignments for very large sequences.")
(home-page "https://github.com/ekg/wfmash")
(license license:expat)))
+
+(define-public go-github-com-biogo-graph
+ (package
+ (name "go-github-com-biogo-graph")
+ (version "0.0.0-20150317020928-057c1989faed")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/biogo/graph")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kpzs5dfd5dsk4mg1g2qjz1prqd84ixhrcxxnf90hq25vxcnk7lh"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/biogo/graph"
+ #:tests? #false)) ;TODO: one of 13 tests fails for unknown reasons
+ (propagated-inputs
+ (list go-gopkg-in-check-v1))
+ (home-page "https://github.com/biogo/graph")
+ (synopsis "Undirected graph analysis for biogo")
+ (description "The package @code{graph} implements graph manipulation
+functions.")
+ (license license:bsd-3)))