aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-24 13:58:01 +0200
committerRoel Janssen <roel@gnu.org>2018-04-24 13:59:39 +0200
commit793f83efe1a13671c4e72dbe095a9984b13e69b3 (patch)
treec5632cfe249dae0a0eb2eaaa7b3c36e4b9d85ca5 /gnu/packages/bioconductor.scm
parenta6ae9ffd6a133828644099453731eac155d6d367 (diff)
downloadguix-793f83efe1a13671c4e72dbe095a9984b13e69b3.tar
guix-793f83efe1a13671c4e72dbe095a9984b13e69b3.tar.gz
gnu: Add r-chippeakanno.
* gnu/packages/bioconductor.scm (r-chippeakanno): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7cf6811d52..9a00baa89b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -185,3 +185,53 @@ reported in terms of adjusted P-values, confidence regions and test statistic
cutoffs. The procedures are directly applicable to identifying differentially
expressed genes in DNA microarray experiments.")
(license license:lgpl3)))
+
+(define-public r-chippeakanno
+ (package
+ (name "r-chippeakanno")
+ (version "3.12.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ChIPpeakAnno" version))
+ (sha256
+ (base32
+ "1zab489d7a6bh6ylc68x6yn47gdkmr7p3677grx9l2qafrryjr04"))))
+ (properties `((upstream-name . "ChIPpeakAnno")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-go-db" ,r-go-db)
+ ("r-biomart" ,r-biomart)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-limma" ,r-limma)
+ ("r-multtest" ,r-multtest)
+ ("r-rbgl" ,r-rbgl)
+ ("r-graph" ,r-graph)
+ ("r-biocinstaller" ,r-biocinstaller)
+ ("r-regioner" ,r-regioner)
+ ("r-dbi" ,r-dbi)
+ ("r-ensembldb" ,r-ensembldb)
+ ("r-biobase" ,r-biobase)
+ ("r-seqinr" ,r-seqinr)
+ ("r-idr" ,r-idr)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-venndiagram" ,r-venndiagram)))
+ (home-page "http://bioconductor.org/packages/ChIPpeakAnno")
+ (synopsis "Peaks annotation from ChIP-seq and ChIP-chip experiments")
+ (description
+ "The package includes functions to retrieve the sequences around the peak,
+obtain enriched Gene Ontology (GO) terms, find the nearest gene, exon, miRNA or
+custom features such as most conserved elements and other transcription factor
+binding sites supplied by users. Starting 2.0.5, new functions have been added
+for finding the peaks with bi-directional promoters with summary statistics
+(peaksNearBDP), for summarizing the occurrence of motifs in peaks
+(summarizePatternInPeaks) and for adding other IDs to annotated peaks or
+enrichedGO (addGeneIDs).")
+ (license license:gpl2+)))