aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-24 13:34:29 +0200
committerRoel Janssen <roel@gnu.org>2018-04-24 13:34:29 +0200
commit6d94bf6baa221bde0e6906df49b79fa289d33e19 (patch)
treea0e5b48df023e7b81e128f1876ff4484e7d432a9 /gnu/packages/bioconductor.scm
parenta5b56a5346ce14c2d5f02ef3e1b4964d8dd4f8d5 (diff)
downloadguix-6d94bf6baa221bde0e6906df49b79fa289d33e19.tar
guix-6d94bf6baa221bde0e6906df49b79fa289d33e19.tar.gz
gnu: Add r-ripseeker.
* gnu/packages/bioconductor.scm (r-ripseeker): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e43b3ff928..4c212ecf02 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -114,3 +114,36 @@ region sets and other genomic features.")
ChIP-seq experiments using affinity (quantitative) data. Also enables
occupancy (overlap) analysis and plotting functions.")
(license license:artistic2.0)))
+
+(define-public r-ripseeker
+ (package
+ (name "r-ripseeker")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "RIPSeeker" version))
+ (sha256
+ (base32
+ "0bqkzwrncww7il36273chkd3gfxmii7p566ycki9qij419pwr35y"))))
+ (properties `((upstream-name . "RIPSeeker")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-s4vectors" ,r-s4vectors)
+ ("r-iranges" ,r-iranges)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-rtracklayer" ,r-rtracklayer)))
+ (home-page "http://bioconductor.org/packages/RIPSeeker")
+ (synopsis
+ "Identifying protein-associated transcripts from RIP-seq experiments")
+ (description
+ "This package infers and discriminates RIP peaks from RIP-seq alignments
+using two-state HMM with negative binomial emission probability. While
+RIPSeeker is specifically tailored for RIP-seq data analysis, it also provides
+a suite of bioinformatics tools integrated within this self-contained software
+package comprehensively addressing issues ranging from post-alignments
+processing to visualization and annotation.")
+ (license license:gpl2)))