aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 21:30:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:56 +0100
commit557a1089c634198b5aee20afb330f92ec204e876 (patch)
treeb7b673fa5238f4b19934f4a581a19233fff48402 /gnu/packages/bioconductor.scm
parent12d73f9c3c809a948046a750e0e88e2a6036bae7 (diff)
downloadguix-557a1089c634198b5aee20afb330f92ec204e876.tar
guix-557a1089c634198b5aee20afb330f92ec204e876.tar.gz
gnu: Add r-hsmmsinglecell.
* gnu/packages/bioconductor.scm (r-hsmmsinglecell): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 8df065a60c..329bacb190 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -33,6 +33,9 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages web))
+
+;;; Annotations
+
(define-public r-bsgenome-celegans-ucsc-ce6
(package
(name "r-bsgenome-celegans-ucsc-ce6")
@@ -647,6 +650,44 @@ based on the knownGene track.")
(license license:artistic2.0)))
+;;; Experiment data
+
+(define-public r-hsmmsinglecell
+ (package
+ (name "r-hsmmsinglecell")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/experiment/" instead of "bioc/".
+ (uri (string-append "https://www.bioconductor.org/packages/"
+ "release/data/experiment/src/contrib/"
+ "HSMMSingleCell_" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vxnr8gr6md85g39csy7g2sqqajiqgyvznys2qa9yixd2b01yph9"))))
+ (properties
+ `((upstream-name . "HSMMSingleCell")))
+ (build-system r-build-system)
+ (home-page "https://www.bioconductor.org/packages/HSMMSingleCell/")
+ (synopsis "Single-cell RNA-Seq for differentiating human skeletal muscle myoblasts (HSMM)")
+ (description
+ "Skeletal myoblasts undergo a well-characterized sequence of
+morphological and transcriptional changes during differentiation. In this
+experiment, primary @dfn{human skeletal muscle myoblasts} (HSMM) were expanded
+under high mitogen conditions (GM) and then differentiated by switching to
+low-mitogen media (DM). RNA-Seq libraries were sequenced from each of several
+hundred cells taken over a time-course of serum-induced differentiation.
+Between 49 and 77 cells were captured at each of four time points (0, 24, 48,
+72 hours) following serum switch using the Fluidigm C1 microfluidic system.
+RNA from each cell was isolated and used to construct mRNA-Seq libraries,
+which were then sequenced to a depth of ~4 million reads per library,
+resulting in a complete gene expression profile for each cell.")
+ (license license:artistic2.0)))
+
+
+;;; Packages
+
(define-public r-biocgenerics
(package
(name "r-biocgenerics")