aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
commit533a893cc6b03f100566760d6e0c8e0500ed7082 (patch)
tree0ecbf89895a400c43d16bb1f6539f1a88aeaa4cf /gnu/packages/benchmark.scm
parent6a2546f92d07df04e5d700924edd027ed1e2ef11 (diff)
parentc762df54786fd6f005f3b5307323f1d2df3cbf0b (diff)
downloadguix-533a893cc6b03f100566760d6e0c8e0500ed7082.tar
guix-533a893cc6b03f100566760d6e0c8e0500ed7082.tar.gz
Merge branch 'master' into staging
Conflicts: .guix-authorizations gnu/ci.scm gnu/packages/base.scm gnu/packages/databases.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/imagemagick.scm gnu/packages/password-utils.scm gnu/packages/python-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm34
1 files changed, 22 insertions, 12 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 3470f3860b..5fd393ee8e 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -1,14 +1,14 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Dave Love <fx@gnu.org>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 malte Frank Gerdes <malte.f.gerdes@gmail.com>
-;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
@@ -51,14 +51,14 @@
(define-public fio
(package
(name "fio")
- (version "3.25")
+ (version "3.26")
(source (origin
(method url-fetch)
(uri (string-append "https://brick.kernel.dk/snaps/"
"fio-" version ".tar.bz2"))
(sha256
(base32
- "16r734an459cz1ax3jyhxc269i3syzdkll4qbv18wqaxpm5y34v6"))))
+ "1114h60vw63bim872an33xpvjfib6sc9dwj9xvk0yw41xjzfpp06"))))
(build-system gnu-build-system)
(arguments
'(#:test-target "test"
@@ -284,14 +284,14 @@ file metadata operations that can be performed per second.")
(define-public python-locust
(package
(name "python-locust")
- (version "1.4.1")
+ (version "1.4.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "locust" version))
(sha256
(base32
- "1q2nza37fwsqf8qdmisfz6bmjpss90shi1bajrclf6gkbslhryxl"))))
+ "0vmw151xcaznd2j85n96iyv9fniss0bkk91xn4maw2gwzym424xk"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -302,8 +302,7 @@ file metadata operations that can be performed per second.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(setenv "PATH" (string-append out "/bin:"
- (getenv "PATH"))))
- #t))
+ (getenv "PATH"))))))
(replace 'check
(lambda _
(invoke "python" "-m" "pytest"
@@ -313,12 +312,19 @@ file metadata operations that can be performed per second.")
"not test_default_headless_spawn_options"
"not test_default_headless_spawn_options_with_shape"
"not test_headless_spawn_options_wo_run_time"
- ;; This test depends on networking.
+ ;; These tests depend on networking.
+ "not test_html_report_option"
"not test_web_options"
;; This test fails because of the warning "System open
;; file limit '1024' is below minimum setting '10000'".
- "not test_skip_logging") " and "))
- #t)))))
+ "not test_skip_logging"
+ ;; On some (slow?) machines, the following tests
+ ;; fail, with the processes returning exit code
+ ;; -15 instead of the expected 42 and 0,
+ ;; respectively (see:
+ ;; https://github.com/locustio/locust/issues/1708).
+ "not test_custom_exit_code"
+ "not test_webserver") " and ")))))))
(propagated-inputs
`(("python-configargparse" ,python-configargparse)
("python-flask" ,python-flask)
@@ -341,5 +347,9 @@ use, scriptable and scalable. The test scenarios are described in plain
Python. It provides a web-based user interface to visualize the results in
real-time, but can also be run non-interactively. Locust is primarily geared
toward testing HTTP-based applications or services, but it can be customized to
-test any system or protocol.")
+test any system or protocol.
+
+Note: Locust will complain if the available open file descriptors limit for
+the user is too low. To raise such limit on a Guix System, refer to
+@samp{info guix --index-search=pam-limits-service}.")
(license license:expat)))