aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bdb.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-08 17:48:03 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-08 17:48:57 +0200
commit5f96f303eb9438d0395ad0b66e92e435531d7700 (patch)
tree543561461535bd69b0439babcc0c589fb0908afc /gnu/packages/bdb.scm
parent971863fb45af749639a556e905997f48e895cfa8 (diff)
downloadguix-5f96f303eb9438d0395ad0b66e92e435531d7700.tar
guix-5f96f303eb9438d0395ad0b66e92e435531d7700.tar.gz
gnu: Consolidate databases in (gnu packages databases).
* gnu/packages/databases.scm: New file, with the contents of the following deleted files. * gnu/packages/mysql.scm, gnu/packages/postgresql.scm, gnu/packages/recutils.scm, gnu/packages/sqlite.scm, gnu/packages/bdb.scm: Remove. * gnu-system.am (GNU_SYSTEM_MODULES): Adjust accordingly. * gnu/packages/apl.scm, gnu/packages/dc.scm, gnu/packages/games.scm, gnu/packages/gnunet.scm, gnu/packages/linux.scm, gnu/packages/mail.scm, gnu/packages/mpd.scm, gnu/packages/nvi.scm, gnu/packages/openldap.scm, gnu/packages/package-management.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/rdf.scm, gnu/packages/version-control.scm: Adjust to new module name.
Diffstat (limited to 'gnu/packages/bdb.scm')
-rw-r--r--gnu/packages/bdb.scm68
1 files changed, 0 insertions, 68 deletions
diff --git a/gnu/packages/bdb.scm b/gnu/packages/bdb.scm
deleted file mode 100644
index e82a683332..0000000000
--- a/gnu/packages/bdb.scm
+++ /dev/null
@@ -1,68 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages bdb)
- #:use-module (gnu packages)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public bdb
- (package
- (name "bdb")
- (version "5.3.21")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://download.oracle.com/berkeley-db/db-" version
- ".tar.gz"))
- (sha256 (base32
- "1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
- (build-system gnu-build-system)
- (outputs '("out" ; programs, libraries, headers
- "doc")) ; 94 MiB of HTML docs
- (arguments
- '(#:tests? #f ; no check target available
- #:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- ;; '--docdir' is not honored, so we need to patch.
- (substitute* "dist/Makefile.in"
- (("docdir[[:blank:]]*=.*")
- (string-append "docdir = " doc "/share/doc/bdb")))
-
- (zero?
- (system* "./dist/configure"
- (string-append "--prefix=" out)
- (string-append "CONFIG_SHELL=" (which "bash"))
- (string-append "SHELL=" (which "bash"))
-
- ;; The compatibility mode is needed by some packages,
- ;; notably iproute2.
- "--enable-compat185"))))
- %standard-phases)))
- (synopsis "db, the Berkeley database")
- (description
- "Berkeley DB is an embeddable database allowing developers the choice of
-SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
- (license (bsd-style "file://LICENSE"
- "See LICENSE in the distribution."))
- (home-page "http://www.oracle.com/us/products/database/berkeley-db/overview/index.html")))