aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-02 15:16:21 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-02 15:16:21 +0200
commite543c8a2c6bdc8f129d02a4b48ff336d0e7b529b (patch)
treea71f22173e7e1485a307b2460057a476ce55e431 /gnu/packages/bash.scm
parent5bde29685b89452d3f584a913b3df5dd41990757 (diff)
downloadguix-e543c8a2c6bdc8f129d02a4b48ff336d0e7b529b.tar
guix-e543c8a2c6bdc8f129d02a4b48ff336d0e7b529b.tar.gz
gnu: bash-minimal: Remove 'move-development-files' phase.
* gnu/packages/bash.scm (bash-minimal)[arguments]: Delete 'move-development-files' phase. (static-bash)[arguments]: Remove deletion of 'move-development-files' phase.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 3b175a5b3c..01168ade16 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -204,7 +204,11 @@ without modification.")
,@(if (%current-target-system)
'("bash_cv_job_control_missing=no")
- '()))))))))
+ '())))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ ;; No loadable modules.
+ (delete 'move-development-files))))))))
(define-public static-bash
;; Statically-linked Bash that contains nothing but the 'bash' binary and
@@ -229,10 +233,7 @@ without modification.")
(remove-store-references (string-append bin "/bash"))
(delete-file (string-append bin "/bashbug"))
(delete-file-recursively (string-append out "/share"))
- #t)))
-
- ;; No loadable modules.
- (delete 'move-development-files))))))))
+ #t))))))))))
(define-public bash-completion
(package