aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-10-06 20:14:03 +0200
committerJohn Darrington <jmd@gnu.org>2016-10-07 06:59:49 +0200
commitc8f354588e5875976566c36c5550b35a47eb1698 (patch)
tree5a5d63f9793f1cac00fc81088145e56312fdd143 /gnu/packages/base.scm
parent12b85b378777393bda24edb30cd974e4a0591e0f (diff)
downloadguix-c8f354588e5875976566c36c5550b35a47eb1698.tar
guix-c8f354588e5875976566c36c5550b35a47eb1698.tar.gz
gnu: tzdata: Use modify-phases
* gnu/packages/base.scm (tzdata)[arguments]: Replace alist- procedures with modify-phases
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 8f1290770a..5aea2cee0e 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -950,23 +950,24 @@ command.")
(guix build gnu-build-system)
(srfi srfi-1))
#:phases
- (alist-replace
- 'unpack
- (lambda* (#:key source inputs #:allow-other-keys)
- (and (zero? (system* "tar" "xvf" source))
- (zero? (system* "tar" "xvf" (assoc-ref inputs "tzcode")))))
- (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Move data in the right place.
- (let ((out (assoc-ref outputs "out")))
- (symlink (string-append out "/share/zoneinfo")
- (string-append out "/share/zoneinfo/posix"))
- (delete-file-recursively (string-append out "/share/zoneinfo-posix"))
- (copy-recursively (string-append out "/share/zoneinfo-leaps")
- (string-append out "/share/zoneinfo/right"))
- (delete-file-recursively (string-append out "/share/zoneinfo-leaps"))))
- (alist-delete 'configure %standard-phases)))))
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key source inputs #:allow-other-keys)
+ (and (zero? (system* "tar" "xvf" source))
+ (zero? (system* "tar" "xvf" (assoc-ref inputs "tzcode"))))))
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Move data in the right place.
+ (let ((out (assoc-ref outputs "out")))
+ (symlink (string-append out "/share/zoneinfo")
+ (string-append out "/share/zoneinfo/posix"))
+ (delete-file-recursively
+ (string-append out "/share/zoneinfo-posix"))
+ (copy-recursively (string-append out "/share/zoneinfo-leaps")
+ (string-append out "/share/zoneinfo/right"))
+ (delete-file-recursively
+ (string-append out "/share/zoneinfo-leaps")))))
+ (delete 'configure))))
(inputs `(("tzcode" ,(origin
(method url-fetch)
(uri (string-append