aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-04-22 22:39:49 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-22 22:40:53 +0200
commitc77835db04ee20c0afe20600dc8f91a67bc2421e (patch)
treed6c500fcd7bb07b233a09ed58c945169a134edab /gnu/packages/base.scm
parentb0ff3606be036ee03f9680285dc167da5ee07e00 (diff)
downloadguix-c77835db04ee20c0afe20600dc8f91a67bc2421e.tar
guix-c77835db04ee20c0afe20600dc8f91a67bc2421e.tar.gz
gnu: tar: Work around a cross-compilation issue.
* gnu/packages/base.scm (tar)[arguments]: Add #:configure-flags when cross-compiling.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index a163018cbd..6d9f019857 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -177,7 +177,7 @@ implementation offers several extensions over the standard utility.")
(build-system gnu-build-system)
;; Note: test suite requires ~1GiB of disk space.
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(#:phases (modify-phases %standard-phases
(add-before 'build 'set-shell-file-name
(lambda* (#:key inputs #:allow-other-keys)
;; Do not use "/bin/sh" to run programs.
@@ -187,6 +187,12 @@ implementation offers several extensions over the standard utility.")
(string-append bash "/bin/sh")))
#t))))
+ ;; Work around a cross-compilation bug whereby libgnu.a would provide
+ ;; '__mktime_internal', which conflicts with the one in libc.a.
+ ,@(if (%current-target-system)
+ `(#:configure-flags '("gl_cv_func_working_mktime=yes"))
+ '())
+
;; Test #92 "link mismatch" expects "a/z: Not linked to a/y" but gets
;; "a/y: Not linked to a/z" and fails, presumably due to differences in
;; the order in which 'diff' traverses directories. That leads to a