aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-03 16:55:21 -0400
committerLeo Famulari <leo@famulari.name>2016-10-03 17:08:23 -0400
commit6524c1cfcf6088c5574e6ff21f540dfb22f944bf (patch)
tree3ae1f4c40c9c86c8311b0f390a3c061fa2af25bb /gnu/packages/backup.scm
parent9c2130757cc0ac20be3cb255c2c09ede45cc9826 (diff)
downloadguix-6524c1cfcf6088c5574e6ff21f540dfb22f944bf.tar
guix-6524c1cfcf6088c5574e6ff21f540dfb22f944bf.tar.gz
gnu: libarchive: Incorporate grafted security patches.
* gnu/packages/backup.scm (libarchive)[source]: Add patches from libarchive/fixed. [replacement]: Remove field. (libarchive/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 797c06e149..fca601fef3 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -172,13 +172,17 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(define-public libarchive
(package
(name "libarchive")
- (replacement libarchive/fixed)
(version "3.2.1")
(source
(origin
(method url-fetch)
(uri (string-append "http://libarchive.org/downloads/libarchive-"
version ".tar.gz"))
+ (patches (search-patches
+ "libarchive-7zip-heap-overflow.patch"
+ "libarchive-fix-symlink-check.patch"
+ "libarchive-fix-filesystem-attacks.patch"
+ "libarchive-safe_fprintf-buffer-overflow.patch"))
(sha256
(base32
"1lngng84k1kkljl74q0cdqc3s82vn2kimfm02dgm4d6m7x71mvkj"))))
@@ -228,17 +232,6 @@ archive. In particular, note that there is currently no built-in support for
random access nor for in-place modification.")
(license license:bsd-2)))
-(define libarchive/fixed
- (package
- (inherit libarchive)
- (source (origin
- (inherit (package-source libarchive))
- (patches (search-patches
- "libarchive-7zip-heap-overflow.patch"
- "libarchive-fix-symlink-check.patch"
- "libarchive-fix-filesystem-attacks.patch"
- "libarchive-safe_fprintf-buffer-overflow.patch"))))))
-
(define-public rdup
(package
(name "rdup")