aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-04-01 16:18:51 -0400
committerLeo Famulari <leo@famulari.name>2018-04-01 22:47:14 -0400
commit620ab3a50ce3c9ec283dd585de48b49c7ca408fc (patch)
tree269f8a499736a92231361244f15569c3ddf246da /gnu/packages/backup.scm
parent66939d59ed0439e2abea53ba97e016ded40539ab (diff)
downloadguix-620ab3a50ce3c9ec283dd585de48b49c7ca408fc.tar
guix-620ab3a50ce3c9ec283dd585de48b49c7ca408fc.tar.gz
gnu: borg: Update to 1.1.5.
* gnu/packages/backup.scm (borg): Update to 1.1.5. [arguments]: Allow a more recent msgpack in an 'adjust-msgpack-dependency' phase.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 2fafa2c4a6..a3782e1296 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -453,13 +453,13 @@ detection, and lossless compression.")
(define-public borg
(package
(name "borg")
- (version "1.1.4")
+ (version "1.1.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
(sha256
- (base32 "1cicqwh85wfp65y00qaq6q4i4jcyy9b66qz5gpl80qc880wab912"))
+ (base32 "0gbdnq7ks46diz6y2pf6wpwkb9hy6hp3immi7jg3h7w72b3ycmj3"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -491,6 +491,17 @@ detection, and lossless compression.")
;; HOME=/homeless-shelter.
(setenv "HOME" "/tmp")
#t)))
+ ;; Later versions of msgpack were disallowed to some warnings and lack
+ ;; of support for Python versions that we don't support anyways. So,
+ ;; it's okay to to keep using more recents versions of msgpack for
+ ;; Borg. Also see the note about msgpack in the list of inputs.
+ ;; https://github.com/borgbackup/borg/issues/3517#issuecomment-357221978
+ (add-before 'build 'adjust-msgpack-dependency
+ (lambda _
+ (substitute* "setup.py"
+ (("msgpack-python>=0.4.6,<0.5.0")
+ "msgpack-python>=0.4.6"))
+ #t))
;; The tests need to be run after Borg is installed.
(delete 'check)
(add-after 'install 'check