aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/axoloti.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
commit6dffced09ecda024e0884e352778c221ad066fd6 (patch)
tree1707e8d8df4d9c47317a39ab6abbfc2ca66a6c29 /gnu/packages/axoloti.scm
parentb603554ed044638dd40b6863d5dada59eefe03b8 (diff)
parente3196755e60ba7f1ed9d432e73f26a85e0c8893c (diff)
downloadguix-6dffced09ecda024e0884e352778c221ad066fd6.tar
guix-6dffced09ecda024e0884e352778c221ad066fd6.tar.gz
Merge branch 'core-updates-frozen' into 'master'.
At last!
Diffstat (limited to 'gnu/packages/axoloti.scm')
-rw-r--r--gnu/packages/axoloti.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/axoloti.scm b/gnu/packages/axoloti.scm
index c6dd748773..f680d6fb83 100644
--- a/gnu/packages/axoloti.scm
+++ b/gnu/packages/axoloti.scm
@@ -205,7 +205,7 @@
;; for uploading compiled patches and firmware
("dfu-util" ,dfu-util-for-axoloti)))
(native-inputs
- `(("unzip" ,unzip)))
+ (list unzip))
(home-page "http://www.axoloti.com/")
(synopsis "Audio development environment for the Axoloti core board")
(description
@@ -318,8 +318,8 @@ runtime.")
(lambda ()
(let* ((dir (string-append (assoc-ref outputs "out")
"/share/axoloti"))
- (runtime (string-append (assoc-ref inputs "axoloti-runtime")
- "/share/axoloti"))
+ (runtime (search-input-directory inputs
+ "share/axoloti"))
(toolchain (assoc-ref inputs "cross-toolchain"))
(includes (string-append
toolchain
@@ -351,9 +351,8 @@ runtime.")
("java-jgit" ,java-jgit-4.2)
("axoloti-runtime" ,axoloti-runtime)))
(native-inputs
- `(("ant" ,ant)
- ("zip" ,zip) ; for repacking the jar
- ("unzip" ,unzip)))
+ (list ant zip ; for repacking the jar
+ unzip))
(description
"The Axoloti patcher offers a “patcher” environment similar to Pure Data
for sketching digital audio algorithms. The patches run on a standalone
@@ -530,8 +529,8 @@ patcher application.")))
;; Install old firmware
(let ((target (string-append share "/old_firmware/firmware-1.0.12"))
(old-firmware
- (string-append (assoc-ref inputs "axoloti-runtime")
- "/share/axoloti/firmware/")))
+ (search-input-directory inputs
+ "share/axoloti/firmware")))
(mkdir-p target)
(install-file (string-append old-firmware
"flasher/flasher_build/flasher.bin")