aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-06 14:52:56 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-06 14:53:10 +0100
commitffc200d7e08862355c7381f45ee7dd772c4d8e83 (patch)
treeb8b73b3d25f697db57665de9b63ba98a7a387409 /gnu/packages/autotools.scm
parent9331ba5dd9dc2224b427d71f2ee56250463f4ef3 (diff)
downloadguix-ffc200d7e08862355c7381f45ee7dd772c4d8e83.tar
guix-ffc200d7e08862355c7381f45ee7dd772c4d8e83.tar.gz
gnu: libtool-2.4.4: Disable tests on MIPS.
* gnu/packages/autotools.scm (libtool-2.4.4)[arguments]: New field.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 3d5c85463f..e45f53d927 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -307,4 +307,13 @@ complexity of working with shared libraries across platforms.")
(native-inputs `(("automake" ,automake) ;some tests rely on 'aclocal'
("autoconf" ,(autoconf-wrapper)) ;others on 'autom4te'
- ,@(package-native-inputs libtool)))))
+ ,@(package-native-inputs libtool)))
+
+ (arguments
+ ;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
+ ;; <http://hydra.gnu.org/build/181662>.
+ (if (string-prefix? "mips64el"
+ (or (%current-target-system) (%current-system)))
+ `(#:tests? #f
+ ,@(package-arguments libtool))
+ (package-arguments libtool)))))