aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/packages/audio.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar
guix-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm71
1 files changed, 60 insertions, 11 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b250bc3af0..f7a675802c 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Christopher Lemmer Webber <cwebber@dustycloud.org>
@@ -78,6 +78,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnunet) ; libmicrohttpd
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -107,6 +108,7 @@
#:use-module (gnu packages serialization)
#:use-module (gnu packages telephony)
#:use-module (gnu packages linphone)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
@@ -495,7 +497,7 @@ implementation of Adaptive Multi Rate Narrowband and Wideband
("jack" ,jack-1)
("ladspa" ,ladspa)
("liblo" ,liblo)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2147,7 +2149,7 @@ synchronous execution of all clients, and low latency operation.")
("gtk2" ,gtk+-2)
("gtk3" ,gtk+)
("gtkmm" ,gtkmm-2)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("jack" ,jack-1)))
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -2739,7 +2741,7 @@ different audio devices such as ALSA or PulseAudio.")
`(("jack" ,jack-1)
("alsa-lib" ,alsa-lib)
("portaudio" ,portaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -2773,11 +2775,11 @@ into various outputs and to start, stop and configure jackd")
(string-append "PREFIX="
(assoc-ref outputs "out"))))))))
(native-inputs
- `(("qtbase" ,qtbase))) ; for qmake
+ `(("qtbase" ,qtbase-5))) ; for qmake
(inputs
`(("jack" ,jack-1)
("libsndfile" ,libsndfile)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://sourceforge.net/projects/qjackrcd/")
(synopsis "Stereo audio recorder for JACK")
(description "QJackRcd is a simple graphical stereo recorder for JACK
@@ -2886,7 +2888,7 @@ link REQUIRED)"))
("boost" ,boost)
("boost-sync" ,boost-sync)
("yaml-cpp" ,yaml-cpp)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtsvg" ,qtsvg)
("qtwebchannel" ,qtwebchannel)
@@ -3088,7 +3090,7 @@ the Turtle syntax.")
`(("lv2" ,lv2)
("gtk+" ,gtk+-2)
("gtk+" ,gtk+)
- ("qt" ,qtbase)))
+ ("qt" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://drobilla.net/software/suil/")
@@ -3564,7 +3566,7 @@ interface.")
("pkg-config" ,pkg-config)))
(inputs
`(("fluidsynth" ,fluidsynth)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)))
(home-page "https://qsynth.sourceforge.io")
(synopsis "Graphical user interface for FluidSynth")
@@ -4740,7 +4742,7 @@ as is the case with audio plugins.")
;; (ModuleNotFoundError: No module named 'PyQt5')
("python-wrapper" ,python-wrapper)
("libx11" ,libx11)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("zlib" ,zlib)
;; For WRAP-SCRIPT above.
@@ -5098,7 +5100,7 @@ Rate} 3600x2250 bit/s vocoder used in various radio systems.")
`(("catch" ,catch-framework)
("python" ,python) ;for running tests
("portaudio" ,portaudio) ;for portaudio examples
- ("qtbase" ,qtbase) ;for Qt examples
+ ("qtbase" ,qtbase-5) ;for Qt examples
("qtdeclarative" ,qtdeclarative)
("qttools" ,qttools)))
(inputs
@@ -5225,3 +5227,50 @@ while still staying in time.")
(description "Butt is a tool to stream audio to a ShoutCast or
Icecast server.")
(license license:gpl2+)))
+
+(define-public siggen
+ (package
+ (name "siggen")
+ (version "2.3.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bleskodev/siggen")
+ (commit "a407611b59d59c7770bbe62ba9b8e9a948cf3210")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0szhgfd9kddr6qsz0imp0x66jjn6ry236f35vjl82ivc1v2bllcb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "INSDIR=" %output "/bin")
+ (string-append "MANDIR=" %output "/share/man"))
+ #:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ ;; Patch misc.c to prevent a segfault.
+ (add-after 'unpack 'patch-segfault
+ (lambda _
+ (substitute* "misc.c"
+ (("#include <stdio.h>\n" all)
+ (string-append all "#include <string.h>\n")))))
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (dir)
+ (mkdir-p (string-append out dir)))
+ (list "/bin" "/share/man/man1" "/share/man/man5"))
+ (apply invoke "make" "sysinstall" make-flags)))))))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (native-inputs
+ `(("groff" ,groff-minimal) ; for nroff
+ ("util-linux" ,util-linux))) ; for col
+ (home-page "https://github.com/bleskodev/siggen")
+ (synopsis "Signal generation tools")
+ (description "siggen is a set of tools for imitating a laboratory signal
+generator, generating audio signals out of Linux's /dev/dsp audio
+device. There is support for mono and/or stereo and 8 or 16 bit samples.")
+ (license license:gpl2)))