aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-16 20:56:38 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-16 20:56:38 +0200
commitdf570bf271536399993b39e7ea2ea0452bb6cde4 (patch)
tree32cde458f90c599691831fc33cfbd4efcca9e9eb /gnu/packages/audio.scm
parent37d203985e2817b0962129384e8b993a1bb92de9 (diff)
parent5f9a9945b5747e5ec284f8b116b2e8cc1b9064d7 (diff)
downloadguix-df570bf271536399993b39e7ea2ea0452bb6cde4.tar
guix-df570bf271536399993b39e7ea2ea0452bb6cde4.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 488d8faf89..82533da4bb 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -145,24 +145,26 @@ Filter) modules follow the convention of 1V / Octave.")
(define-public aubio
(package
(name "aubio")
- (version "0.4.1")
+ (version "0.4.6")
(source (origin
(method url-fetch)
(uri (string-append
- "http://aubio.org/pub/aubio-" version ".tar.bz2"))
+ "https://aubio.org/pub/aubio-" version ".tar.bz2"))
(sha256
(base32
- "15f6nf76y7iyl2kl4ny7ky0zpxfxr8j3902afvd6ydnnkh5dzmr5"))))
+ "1yvwskahx1bf3x2fvi6cwah1ay11iarh79fjlqz8s887y3hkpixx"))))
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
#:configure-flags
- '("--enable-fftw3f"
- "--enable-jack"
- "--enable-sndfile"
- "--enable-samplerate"
- ;; enable compilation with avcodec once available
- "--disable-avcodec")
+ (list
+ (string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out") "/lib")
+ "--enable-fftw3f"
+ "--enable-jack"
+ "--enable-sndfile"
+ "--enable-samplerate"
+ ;; TODO: enable compilation with avcodec once available.
+ "--disable-avcodec")
#:python ,python-2))
(inputs
`(("jack" ,jack-1)
@@ -171,7 +173,7 @@ Filter) modules follow the convention of 1V / Octave.")
("fftwf" ,fftwf)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://aubio.org/")
+ (home-page "https://aubio.org/")
(synopsis "Library for audio labelling")
(description
"aubio is a tool designed for the extraction of annotations from audio
@@ -463,14 +465,14 @@ plugins are provided.")
(define-public calf
(package
(name "calf")
- (version "0.90.0")
+ (version "0.90.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://calf-studio-gear.org/files/calf-"
+ (uri (string-append "https://calf-studio-gear.org/files/calf-"
version ".tar.gz"))
(sha256
(base32
- "0dijv2j7vlp76l10s4v8gbav26ibaqk8s24ci74vrc398xy00cib"))))
+ "0znwx5gidr5n503gya9n8gagr8cfym6cwlbiv2r6iksji7jc4fpb"))))
(build-system gnu-build-system)
(inputs
`(("fluidsynth" ,fluidsynth)
@@ -1726,7 +1728,7 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
"0f24cd7wkk5l969857g2ydz2kjjrkvvddg1g87xzzs78lsvq8fy3"))))
(build-system waf-build-system)
(arguments
- `(#:tests? #f ; no check target
+ `(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
(add-before
@@ -1736,7 +1738,7 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
(string-append "-Wl,-rpath="
(assoc-ref outputs "out") "/lib"))
#t)))))
- ;; required by lilv-0.pc
+ ;; Required by lilv-0.pc.
(propagated-inputs
`(("serd" ,serd)
("sord" ,sord)
@@ -2744,7 +2746,7 @@ interface.")
(define-public qsynth
(package
(name "qsynth")
- (version "0.5.1")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
@@ -2752,10 +2754,10 @@ interface.")
"/qsynth-" version ".tar.gz"))
(sha256
(base32
- "0kpk1rnhbifbvm4xvw8i0d4ksk78pf505qvg08k89kqkg32494ap"))))
+ "1rfkaxq1pyc4hv3l0i6wicianbcbm1wp53kh9i5d4jsljgisd1dv"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no "check" phase
+ `(#:tests? #f ; no "check" phase
#:configure-flags
'("CXXFLAGS=-std=gnu++11")))
(native-inputs