aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2024-08-04 18:28:36 +0000
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:47 +0200
commit77e99a79eb744509c2f896c177b6d2870b394f20 (patch)
tree90a1403e63dad418bb5f78f6e927530ca1b8f2b0 /gnu/packages/audio.scm
parent2ad3b0187b5d893cc694a9c436b32ca001aa4816 (diff)
downloadguix-77e99a79eb744509c2f896c177b6d2870b394f20.tar
guix-77e99a79eb744509c2f896c177b6d2870b394f20.tar.gz
gnu: webrtc-audio-processing: Fix build on i686 and powerpc64le.
* gnu/packages/audio.scm (webrtc-audio-processing)[arguments]: New field. * gnu/packages/patches/webrtc-audio-processing-byte-order-pointer-size.patch, gnu/packages/patches/webrtc-audio-processing-x86-no-sse.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Change-Id: I3a95e5e2794df0d51e005672b5d3e2d98f27b767 Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 52033c46ab..6be49f7768 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -315,6 +315,28 @@ displays a histogram of the roundtrip time jitter.")
(sha256
(base32 "0xfvq5lxg612vfzk3zk6896zcb4cgrrb7fq76w9h40magz0jymcm"))))
(build-system meson-build-system)
+ (arguments
+ (list #:configure-flags (if (target-x86-32?)
+ #~(list "-Dc_args=-DPFFFT_SIMD_DISABLE")
+ #~'())
+ #:phases
+ (if (or (target-x86-32?) (target-powerpc?))
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'apply-patches
+ (lambda _
+ (define (patch file)
+ (invoke "patch" "-p1" "--force" "-i" file))
+
+ ;; https://gitlab.freedesktop.org/pulseaudio/webrtc-audio-processing/-/issues/5
+ ;; TODO: Move to the 'patches' field of the origin on
+ ;; the next rebuild.
+ (patch #$(local-file
+ (search-patch
+ "webrtc-audio-processing-byte-order-pointer-size.patch")))
+ (patch #$(local-file
+ (search-patch
+ "webrtc-audio-processing-x86-no-sse.patch"))))))
+ #~%standard-phases)))
(native-inputs (list pkg-config))
(inputs (list abseil-cpp))
(synopsis "WebRTC's Audio Processing Library")