aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/astronomy.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0a1c556b85..d88a0ef739 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -200,10 +200,7 @@ for reading and writing.")
(base32 "0nh12dr7gk4ki55lz95pkm4fpf7kazirra3zax9pab6v4qql4hlw"))))
(build-system gnu-build-system)
(native-inputs
- `(("automake" ,automake)
- ("autoreconf" ,autoconf)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list automake autoconf libtool pkg-config))
(home-page "https://github.com/liberfa/erfa")
(synopsis "Essential Routines for Fundamental Astronomy")
(description
@@ -1224,10 +1221,9 @@ functions, so that they can be called with scalar or array inputs.")
(base32 "0wxdqn92q1grv8k7xi7h88ac6wnznw4xh5bdlz1vz6za2dgsyj4m"))))
(build-system python-build-system)
(native-inputs
- `(("cython" ,python-cython)
- ("pytest" ,python-pytest)))
+ (list python-cython python-pytest))
(inputs
- `(("numpy" ,python-numpy)))
+ (list python-numpy))
(home-page "https://github.com/kbarbary/sep")
(synopsis "Astronomical source extraction and photometry library")
(description