aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-24 19:56:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-24 19:56:35 +0200
commit706ae8e15c8d36b0aee7c19c54c143d3e17f5784 (patch)
treee9fe8ebfb1417d30979b5413165599f066a1c504 /gnu/packages/aspell.scm
parent3e95125e9bd0676d4a9add9105217ad3eaef3ff0 (diff)
parent8440db459a10daa24282038f35bc0b6771bd51ab (diff)
downloadguix-706ae8e15c8d36b0aee7c19c54c143d3e17f5784.tar
guix-706ae8e15c8d36b0aee7c19c54c143d3e17f5784.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 1e2149cd2c..993dc560eb 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -27,6 +27,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix licenses)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
@@ -49,6 +50,19 @@
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'build 'set-filter-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Change the default value of 'filter-path' so that filters such
+ ;; as 'tex-filter.so' can be found. By default none of the
+ ;; filters would be found.
+ (let* ((out (assoc-ref outputs "out"))
+ (libdir (string-append out "/lib/aspell-"
+ ,(version-major+minor version))))
+ (substitute* "common/config.cpp"
+ (("\"filter-path(.*)DICT_DIR" _ middle)
+ (string-append "\"filter-path" middle
+ "\"" libdir "\"")))
+ #t)))
(add-after 'install 'wrap-aspell
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin/aspell (string-append (assoc-ref outputs "out")
@@ -141,10 +155,10 @@ dictionaries, including personal ones.")
(define-public aspell-dict-en
(aspell-dictionary "en" "English"
- #:version "2017.08.24-0"
+ #:version "2018.04.16-0"
#:sha256
(base32
- "0z2vvm1by485cm0sna21cmw6zb771c2l2lnn676zmrwm46q65d89")))
+ "0bxxdzkk9g27plg22y9qzsx9cfjw3aa29w5bmzs561qc9gkp247i")))
(define-public aspell-dict-eo
(aspell-dictionary "eo" "Esperanto"