aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-01-08 14:23:12 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-02 21:16:59 +0100
commit81fc64da7e9fa5eed782d0c52ebd5c76598e045a (patch)
tree3519e3eb20f6ae7d4adae7ed9d1397ca0e315092 /gnu/packages/aspell.scm
parent8c44dabc5a54e51cca2b217899438b1055c09d59 (diff)
downloadguix-81fc64da7e9fa5eed782d0c52ebd5c76598e045a.tar
guix-81fc64da7e9fa5eed782d0c52ebd5c76598e045a.tar.gz
gnu: aspell: Wrap binary to find dictionaries.
* gnu/packages/aspell.scm (aspell): Add 'wrap-aspell' phase. * gnu/system.scm (operating-system-etc-service): Remove 'ASPELL_CONF' definition. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 2425d1cbec..ede217078f 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -38,6 +38,16 @@
(base32
"1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-aspell
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin/aspell (string-append (assoc-ref outputs "out")
+ "/bin/aspell")))
+ (wrap-program bin/aspell
+ '("ASPELL_CONF" "" =
+ ("${ASPELL_CONF:-\"dict-dir ${GUIX_PROFILE:-$HOME/.guix-profile}/lib/aspell\"}")))))))))
(inputs `(("perl" ,perl)))
(home-page "http://aspell.net/")
(synopsis "Spell checker")