aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/animation.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/animation.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/animation.scm')
-rw-r--r--gnu/packages/animation.scm21
1 files changed, 6 insertions, 15 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 063103e433..c281772563 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -82,8 +82,7 @@
"-Dlog=true"
"-Dtest=true")))
(native-inputs
- `(("googletest" ,googletest)
- ("pkg-config" ,pkg-config)))
+ (list googletest pkg-config))
(synopsis "Lottie Animation Library")
(description "Rlottie is a platform independent standalone c++ library for
rendering vector based animations and art in realtime.")
@@ -182,8 +181,7 @@ C++ @dfn{Standard Template Library} (STL).")
("openexr" ,openexr-2)
("pango" ,pango)))
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ (list intltool pkg-config))
(home-page "https://www.synfig.org")
(synopsis "Vector-based 2D animation renderer")
(description
@@ -225,13 +223,9 @@ for tweening, preventing the need to hand-draw each frame.")
`("XDG_DATA_DIRS" ":" prefix (,gtk-share)))
#t))))))
(inputs
- `(("gtkmm" ,gtkmm-3)
- ("gtk+" ,gtk+)
- ("libsigc++" ,libsigc++)
- ("synfig" ,synfig)))
+ (list gtkmm-3 gtk+ libsigc++ synfig))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("intltool" ,intltool)))
+ (list pkg-config intltool))
(home-page "https://www.synfig.org")
(synopsis "Vector-based 2D animation package (GUI)")
(description
@@ -454,7 +448,7 @@ language.")
("qtmultimedia" ,qtmultimedia)
("libsndfile" ,libsndfile)))
(native-inputs
- `(("qttools" ,qttools)))
+ (list qttools))
(home-page "https://www.lostmarble.com/papagayo/")
(synopsis "Lip-syncing for animations")
(description
@@ -480,10 +474,7 @@ waveform until they line up with the proper sounds.")
"0b1nwiwyg01087q318vymg4si76dw41ykxbn2zwd6dqbxzbpr1dh"))))
(build-system gnu-build-system)
(inputs
- `(("qtbase" ,qtbase-5)
- ("qtxmlpatterns" ,qtxmlpatterns)
- ("qtmultimedia" ,qtmultimedia)
- ("qtsvg" ,qtsvg)))
+ (list qtbase-5 qtxmlpatterns qtmultimedia qtsvg))
(arguments
`(#:phases
(modify-phases %standard-phases