aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-05-09 20:04:33 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-05-09 22:32:33 +0200
commit055e6fb3eb12b863ce6176f682fee62a36387b24 (patch)
tree56bd68a20d83dae79fdbce19f6f6a1ddb1699b25 /gnu/packages/android.scm
parent2d804f9202fa7f51daf22af98a542e363c56fc57 (diff)
downloadguix-055e6fb3eb12b863ce6176f682fee62a36387b24.tar
guix-055e6fb3eb12b863ce6176f682fee62a36387b24.tar.gz
gnu: Add android-f2fs-utils.
* gnu/packages/android.scm (android-f2fs-utils): New variable.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 6e44369f72..21b0c7c64c 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -507,6 +507,35 @@ that is safe to use for user space. It also includes
Android core.")
(license license:asl2.0)))
+(define-public android-f2fs-utils
+ (package
+ (name "android-f2fs-utils")
+ (version (android-platform-version))
+ (source (android-platform-system-extras version))
+ (build-system android-ndk-build-system)
+ (arguments
+ `(#:tests? #f ; TODO.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-source
+ (lambda _ (chdir "f2fs_utils") #t))
+ (add-after 'install 'install-headers
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (copy-recursively "." (string-append (assoc-ref outputs "out")
+ "/include"))
+ #t)))))
+ (inputs
+ `(("f2fs-tools" ,f2fs-tools-1.7)
+ ("android-libselinux" ,android-libselinux)
+ ("android-libsparse" ,android-libsparse)
+ ("libcutils" ,libcutils)
+ ("zlib" ,zlib)))
+ (home-page "https://developer.android.com/")
+ (synopsis "Android ext4 utils")
+ (description "@code{android-ext4-utils} is a library in common use by the
+Android core.")
+ (license license:asl2.0)))
+
(define-public android-udev-rules
(package
(name "android-udev-rules")