aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-03-22 11:42:22 +0100
committerLudovic Courtès <ludo@gnu.org>2018-03-22 11:43:30 +0100
commitca5b73114f13e6f34ded3c415721939c196e07dd (patch)
tree11cd8f82d7299f5817831d0b9507c7dacc7125fd /gnu/packages/admin.scm
parent7fe1432a2ec2b8a7dfbfe882044dadadccd2e2c8 (diff)
downloadguix-ca5b73114f13e6f34ded3c415721939c196e07dd.tar
guix-ca5b73114f13e6f34ded3c415721939c196e07dd.tar.gz
gnu: shepherd: Update to 0.4.0.
* gnu/packages/admin.scm (shepherd): Update to 0.4.0. Remove patches. * gnu/packages/patches/shepherd-close-fds.patch, gnu/packages/patches/shepherd-herd-status-sorted.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/services/admin.scm (%default-rotations): Remove /var/log/shepherd.log.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 7a9f79ede0..6ed1c322fa 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -159,16 +159,14 @@ and provides a \"top-like\" mode (monitoring).")
(define-public shepherd
(package
(name "shepherd")
- (version "0.3.2")
+ (version "0.4.0")
(source (origin
(method url-fetch)
- (uri (string-append "ftp://alpha.gnu.org/gnu/dmd/shepherd-"
+ (uri (string-append "https://alpha.gnu.org/gnu/shepherd/shepherd-"
version ".tar.gz"))
(sha256
(base32
- "174q1qg7yg6w1hfvlfv720hr6hid4h5xzw15y3ycfpspllzldhcb"))
- (patches (search-patches "shepherd-close-fds.patch"
- "shepherd-herd-status-sorted.patch"))))
+ "1lgmsbxn8i8xdasxzkdp2cml75n128pplw6icvmspl6s0n9xmw8n"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--localstatedir=/var")))