aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-18 03:26:48 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-18 05:38:38 +0200
commitb94cb3be2ad3fdad73ce8473622109b31217c324 (patch)
treefb436d73a5dc66a00c627bcd0ba636b392bcfca6 /gnu/packages/admin.scm
parent01af05bf0bc8d46ff67d79fad662ed0eb23eda47 (diff)
downloadguix-b94cb3be2ad3fdad73ce8473622109b31217c324.tar
guix-b94cb3be2ad3fdad73ce8473622109b31217c324.tar.gz
gnu: jc: Update to 1.13.4.
* gnu/packages/admin.scm (jc): Update to 1.13.4.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1183dc5085..e99e103936 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3984,21 +3984,22 @@ supplied by the user when logging in.")
(define-public jc
(package
(name "jc")
- (version "1.11.8")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kellyjonbrazil/jc")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0rkckbgm04ql4r48wjgljfiqvsz36n99yqcpcyna8lvlm8h4nmwa"))))
+ (version "1.13.4")
+ (source
+ (origin
+ ;; The PyPI tarball lacks the test suite.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kellyjonbrazil/jc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rwvyyrdnw43pixp8h51rncq2inc9pbbj1j2191y5si00pjw34zr"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-ruamel.yaml" ,python-ruamel.yaml)
- ("python-xmltodict" ,python-xmltodict)
- ("python-pygments" ,python-pygments)))
+ `(("python-pygments" ,python-pygments)
+ ("python-ruamel.yaml" ,python-ruamel.yaml)
+ ("python-xmltodict" ,python-xmltodict)))
(home-page "https://github.com/kellyjonbrazil/jc")
(synopsis "Convert the output of command-line tools to JSON")
(description "@code{jc} JSONifies the output of many CLI tools and