aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorEthan R. Jones <doubleplusgood23@gmail.com>2017-05-08 16:14:21 -0400
committerRicardo Wurmus <rekado@elephly.net>2017-05-08 23:11:01 +0200
commit6e75ea481b9ff8cf65e9c5bd206bb611e1ef906f (patch)
tree68c68f79a71c00f4db24bd2f4b16507b7211c8ac /gnu/packages/admin.scm
parente586257b550918fefaab3970f2c314d6285f54ab (diff)
downloadguix-6e75ea481b9ff8cf65e9c5bd206bb611e1ef906f.tar
guix-6e75ea481b9ff8cf65e9c5bd206bb611e1ef906f.tar.gz
gnu: Add neofetch.
* gnu/packages/admin.scm (neofetch): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9feacb1e8b..ff0431999d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
+;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2088,3 +2089,44 @@ It is similar to Capistrano, except it's implemented in Python and doesn't
expect you to be deploying Rails applications. Fabric is a simple, Pythonic
tool for remote execution and deployment.")
(license license:bsd-2)))
+
+(define-public neofetch
+ (package
+ (name "neofetch")
+ (version "3.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dylanaraps/neofetch/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rgznkl7a5q7lnc6zxlwvinq20b7k46n949l1hiwifarv0jgwynv"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; there are no tests
+ #:make-flags
+ (list (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-target-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("\\$\\(DESTDIR\\)/etc/")
+ "$(PREFIX)/etc/"))
+ (substitute* "neofetch"
+ (("\"/etc/neofetch")
+ (string-append "\"" out "/etc/neofetch"))
+ (("\"/usr/share/neofetch")
+ (string-append "\"" out "/usr/share/neofetch"))))
+ #t))
+ (delete 'configure))))
+ (home-page "https://github.com/dylanaraps/neofetch")
+ (synopsis "System info script")
+ (description "Neofetch is a CLI system information tool written in Bash.
+Neofetch displays information about your system next to an image, your OS
+logo, or any ASCII file of your choice. The main purpose of Neofetch is to be
+used in screenshots to show other users what operating system or distribution
+you are running, what theme or icon set you are using, etc.")
+ (license license:expat)))