aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:06:27 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:06:27 +0100
commit03e856ddf5d28bc61144effb1a393b73cb4a2d9f (patch)
treef477e079cbdb4b274130e4fcb6c6a5acb781eedf /gnu/packages/admin.scm
parent072f1e22cc6b1708fddedd1ac7ab12827284a785 (diff)
parent80983df357856fe4e65e384a655e466164e049a1 (diff)
downloadguix-03e856ddf5d28bc61144effb1a393b73cb4a2d9f.tar
guix-03e856ddf5d28bc61144effb1a393b73cb4a2d9f.tar.gz
Merge branch 'python-build-system'.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5adde6cc4a..f1c283c7c2 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1332,8 +1332,6 @@ specified directories.")
(("/usr") out)
(("distro_ver = .*") "distro_ver = ''"))
#t))))))
- (inputs
- `(("python-setuptools" ,python2-setuptools)))
(home-page "https://github.com/shawn-sterling/graphios")
(synopsis "Emit Nagios metrics to Graphite, Statsd, and Librato")
(description
@@ -1356,8 +1354,7 @@ of supported upstream metrics systems simultaneously.")
"1bfc2xiplpad6f2nwi48y0kps7xqnsll85dlz63cy8k5bysl6d20"))))
(build-system python-build-system)
(native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ("python2-pycrypto" ,python2-pycrypto)
+ `(("python2-pycrypto" ,python2-pycrypto)
("python2-httplib2" ,python2-httplib2)
("python2-passlib" ,python2-passlib)
("python2-nose" ,python2-nose)
@@ -1699,13 +1696,15 @@ throughput (in the same interval).")
(base32
"04q2cn8c83f6z6wn1scla1ilrpi5ssjc64987hvmwfvwvb82bvkp"))))
(build-system python-build-system)
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
(inputs
`(("python-colorama" ,python-colorama)
("python-decorator" ,python-decorator)
("python-psutil" ,python-psutil)
("python-six" ,python-six)))
+ (inputs
+ ;; Requires setuptools >= 17.1 due to some features used, while our
+ ;; python currently only includes 12.0. TODO: Remove this input.
+ `(("python-setuptools" ,python-setuptools)))
(home-page "https://github.com/nvbn/thefuck")
(synopsis "Correct mistyped console command")
(description