aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-14 18:09:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-14 18:31:35 +0100
commitf63495d31bf5acad00b6ee5f44a0553a67ee91fb (patch)
treeaf3ed054e9e3784670ef55f5ae6480aaab551be6 /gnu/packages/admin.scm
parente8b79cd9f449c0419f1d4f09d7b8e0712b6a961f (diff)
downloadguix-f63495d31bf5acad00b6ee5f44a0553a67ee91fb.tar
guix-f63495d31bf5acad00b6ee5f44a0553a67ee91fb.tar.gz
gnu: guile: Apply Shepherd fix to the default Guile.
* gnu/packages/guile.scm (guile-2.2/bug-fix): Remove variable. (guile-2.2)[source](patches): Add "guile-finalization-crash.patch". * gnu/packages/admin.scm (shepherd)[inputs, native-inputs]: Change from GUILE-2.2/BUG-FIX to GUILE-2.2.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 0790925416..460228db61 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -211,10 +211,10 @@ and provides a \"top-like\" mode (monitoring).")
`(("pkg-config" ,pkg-config)
;; This is the Guile we use as a cross-compiler...
- ("guile" ,guile-2.2/bug-fix)))
+ ("guile" ,guile-2.2)))
(inputs
;; ... and this is the one that appears in shebangs when cross-compiling.
- `(("guile" ,guile-2.2/bug-fix) ;for <https://bugs.gnu.org/37757>
+ `(("guile" ,guile-2.2) ;for <https://bugs.gnu.org/37757>
;; The 'shepherd' command uses Readline when used interactively. It's
;; an unusual use case though, so we don't propagate it.