aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 03:03:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 03:10:08 +0200
commitdca48d3cf19db5e1b12c70cadbecb5791e0b3df8 (patch)
treeec84413fa5c8ee1434c4cf9ac28d91231947d85d /gnu/packages/admin.scm
parent4a6785f6c0ecf46b1792a29117c83be2260e707f (diff)
downloadguix-dca48d3cf19db5e1b12c70cadbecb5791e0b3df8.tar
guix-dca48d3cf19db5e1b12c70cadbecb5791e0b3df8.tar.gz
gnu: igt-gpu-tools: Update to 1.23.
* gnu/packages/admin.scm (intel-gpu-tools): Redefine using DEPRECATED-PACKAGE. Move the previous package definition from here... (igt-gpu-tools): ...to here, and update to 1.23. [name, source, description]: Adjust to new name. [inputs]: Add openssl.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ed4c7bb075..0194cbf137 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2267,21 +2267,21 @@ With sedsed you can master any sed script. No more secrets, no more hidden
buffers.")
(license license:expat)))
-(define-public intel-gpu-tools
+(define-public igt-gpu-tools
(package
- (name "intel-gpu-tools")
- (version "1.22")
+ (name "igt-gpu-tools")
+ (version "1.23")
(source (origin
(method url-fetch)
(uri (string-append "https://cgit.freedesktop.org/xorg/app/"
"intel-gpu-tools/snapshot/"
- "intel-gpu-tools-" version ".tar.gz"))
+ name "-" version ".tar.gz"))
(sha256
(base32
- "1jx5w5fr6jp67rcrlp5v79cn8kp9n0wgd5pbfgzamlah5cx6j3yd"))))
+ "0vzv2i4jfv2pkbqby5k3ap9pzidkmajwqmg3s7wnv8i1h33775iq"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; many of the tests try to load kernel modules
+ `(#:tests? #f ; many of the tests try to load kernel modules
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'autogen
@@ -2299,7 +2299,8 @@ buffers.")
("cairo" ,cairo)
("libunwind" ,libunwind)
("libxrandr" ,libxrandr)
- ("glib" ,glib)))
+ ("glib" ,glib)
+ ("openssl" ,openssl)))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -2307,17 +2308,20 @@ buffers.")
("pkg-config" ,pkg-config)))
(home-page "https://cgit.freedesktop.org/xorg/app/intel-gpu-tools/")
(synopsis "Tools for development and testing of the Intel DRM driver")
- (description "Intel GPU Tools is a collection of tools for development and
+ (description "IGT GPU Tools is a collection of tools for development and
testing of the Intel DRM driver. There are many macro-level test suites that
get used against the driver, including xtest, rendercheck, piglit, and
oglconform, but failures from those can be difficult to track down to kernel
changes, and many require complicated build procedures or specific testing
-environments to get useful results. Therefore, Intel GPU Tools includes
+environments to get useful results. Therefore, IGT GPU Tools includes
low-level tools and tests specifically for development and testing of the
Intel DRM Driver.")
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:expat)))
+(define-public intel-gpu-tools
+ (deprecated-package "intel-gpu-tools" igt-gpu-tools))
+
(define-public fabric
(package
(name "fabric")