aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-25 17:45:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-25 20:44:38 +0200
commit00f81f83a1e2c7f57f937ceb70e345f798a40151 (patch)
treeda4fa80cfb87371729c22b3bee3046c3f67d99c3 /gnu/packages/admin.scm
parent95da60845127731f1395f8a7f5ab7e235aca5dfc (diff)
downloadguix-00f81f83a1e2c7f57f937ceb70e345f798a40151.tar
guix-00f81f83a1e2c7f57f937ceb70e345f798a40151.tar.gz
gnu: audit: Update to 2.8.4.
* gnu/packages/admin.scm (audit): Update to 2.8.4. [arguments]: Remove #:phases.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm20
1 files changed, 5 insertions, 15 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 29651f7c48..df569dd307 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1773,27 +1773,17 @@ platform-specific methods.")
(define-public audit
(package
(name "audit")
- (version "2.4.5")
+ (home-page "https://people.redhat.com/sgrubb/audit/")
+ (version "2.8.4")
(source (origin
(method url-fetch)
- (uri (string-append "https://people.redhat.com/sgrubb/audit/"
- "audit-" version ".tar.gz"))
+ (uri (string-append home-page name "-" version ".tar.gz"))
(sha256
(base32
- "1q1q51dvxscbi4kbakmd4bn0xrvwwaiwvaya79925cbrqwzxsg77"))))
+ "0f4ci6ffznnmgblwgv7ich9mjfk3p6y5l6m6h3chhmzw156nj454"))))
(build-system gnu-build-system)
- (home-page "https://people.redhat.com/sgrubb/audit/")
(arguments
- `(#:configure-flags (list "--with-python=no")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda _
- ;; In the build environmnte /etc/passwd does not contain an entry
- ;; for root/0, so we have to patch the expected value.
- (substitute* "auparse/test/auparse_test.ref"
- (("=0 \\(root\\)") "=0 (unknown(0))"))
- #t)))))
+ `(#:configure-flags (list "--with-python=no")))
(inputs
`(("openldap" ,openldap)
("gnutls" ,gnutls)