aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer.scm
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-09-27 11:00:27 +0200
committerLudovic Courtès <ludo@gnu.org>2024-09-28 12:55:54 +0200
commit8e5c8303a414719c19a597247674be87fd500d45 (patch)
tree74fb47877a73e88cd47a1f0072963de8d764fac1 /gnu/installer.scm
parent73c5f1df053f34a3f0eb2bbdbe0279cd3dd9743f (diff)
downloadguix-8e5c8303a414719c19a597247674be87fd500d45.tar
guix-8e5c8303a414719c19a597247674be87fd500d45.tar.gz
gnu: iso-codes: Rename to iso-codes/pinned.
* gnu/packages/iso-codes.scm (iso-codes): Rename to… (iso-codes/pinned): … this. * doc/build.scm, gnu/installer.scm, gnu/packages/fcitx.scm, gnu/packages/fcitx5.scm, gnu/packages/gnome.scm, gnu/packages/gstreamer.scm, gnu/packages/gtk.scm, gnu/packages/ibus.scm, gnu/packages/kde-frameworks.scm, gnu/packages/kde-plasma.scm, gnu/packages/mate.scm, gnu/packages/photo.scm, gnu/packages/video.scm: Adjust accordingly. Change-Id: Ia98fee15a27009583fee822cf411512727b1aa27 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/installer.scm')
-rw-r--r--gnu/installer.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index 3792fc7e35..53af01261e 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -146,10 +146,10 @@ been performed at build time."
(let* ((supported-locales #~(supported-locales->locales
#+(glibc-supported-locales)))
- (iso-codes #~(string-append #$iso-codes "/share/iso-codes/json/"))
- (iso639-3 #~(string-append #$iso-codes "iso_639-3.json"))
- (iso639-5 #~(string-append #$iso-codes "iso_639-5.json"))
- (iso3166 #~(string-append #$iso-codes "iso_3166-1.json"))
+ (iso-codes #~(string-append #$iso-codes/pinned "/share/iso-codes/json/"))
+ (iso639-3 #~(string-append #$iso-codes/pinned "iso_639-3.json"))
+ (iso639-5 #~(string-append #$iso-codes/pinned "iso_639-5.json"))
+ (iso3166 #~(string-append #$iso-codes/pinned "iso_3166-1.json"))
(locales-file (build-compiled-file
locales-name
#~`(quote ,#$supported-locales)))
@@ -437,9 +437,9 @@ purposes."
;; (e.g., "French" is always displayed as "français", but
;; "Belgium" could be translated to Dutch, French, or German.)
(bindtextdomain "iso_639-3" ;languages
- #+(file-append iso-codes "/share/locale"))
+ #+(file-append iso-codes/pinned "/share/locale"))
(bindtextdomain "iso_3166-1" ;territories
- #+(file-append iso-codes "/share/locale"))
+ #+(file-append iso-codes/pinned "/share/locale"))
;; Likewise for XKB keyboard layout names.
(bindtextdomain "xkeyboard-config"