aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/jami-service.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:24:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:27:28 -0400
commit3c6e220d8100281074c414a43c1efe9a01b53771 (patch)
treedc5d47fbbac3842d0da893adcd398dea10c1e681 /gnu/build/jami-service.scm
parent08473753a0ebafef22c0894d846e3b42fd6be2a2 (diff)
parent62048ff9fcfbe3fc790a7207fc5f6f3e0476a02a (diff)
downloadguix-3c6e220d8100281074c414a43c1efe9a01b53771.tar
guix-3c6e220d8100281074c414a43c1efe9a01b53771.tar.gz
Merge branch 'master' into staging.
With resolved conflicts in: gnu/local.mk gnu/packages/crates-io.scm
Diffstat (limited to 'gnu/build/jami-service.scm')
-rw-r--r--gnu/build/jami-service.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/build/jami-service.scm b/gnu/build/jami-service.scm
index 0ceb03eb02..a00785f699 100644
--- a/gnu/build/jami-service.scm
+++ b/gnu/build/jami-service.scm
@@ -153,14 +153,11 @@ implementation detail used to identify the accounts in Jami."
(error message username))))
(define (account->username account)
- "Return USERNAME, the registered username associated with ACCOUNT, else its
-public key fingerprint."
- (or (assoc-ref account "Account.registeredName")
- (assoc-ref account "Account.username")))
+ "Return the public key fingerprint of ACCOUNT."
+ (assoc-ref account "Account.username"))
(define (id->username id)
- "Return USERNAME, the registered username associated with ID, else its
-public key fingerprint, else #f."
+ "Return the public key fingerprint corresponding to account with ID, else #f."
(account->username (id->account id)))
(define (get-accounts)