aboutsummaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-09-25 12:41:33 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-09-25 12:42:11 +0200
commit9943bbfaa18fb3b63f2c39a4af44e431facbadfd (patch)
tree82e2765780814b13edc080c8682a75c8d2c2dbc9 /etc
parentb6aef666d912c9d51e3265c61d0bd36ee579dda3 (diff)
downloadguix-9943bbfaa18fb3b63f2c39a4af44e431facbadfd.tar
guix-9943bbfaa18fb3b63f2c39a4af44e431facbadfd.tar.gz
etc: teams: Define python team scope.
* etc/teams.scm.in (python): Define it.
Diffstat (limited to 'etc')
-rw-r--r--etc/teams.scm.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index e97801a561..b517e6e0cb 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -92,7 +92,19 @@
(team 'python
#:name "Python team"
#:description
- "Python, Python packages, the \"pypi\" importer, and the python-build-system."))
+ "Python, Python packages, the \"pypi\" importer, and the python-build-system."
+ #:scope
+ (list "gnu/packages/django.scm"
+ "gnu/packages/jupyter.scm"
+ ;; Match haskell.scm and haskell-*.scm.
+ (make-regexp "^gnu/packages/python(-.+|)\\.scm$")
+ "gnu/packages/sphinx.scm"
+ "gnu/packages/tryton.scm"
+ "guix/build/python-build-system.scm"
+ "guix/build-system/python.scm"
+ "guix/import/pypi.scm"
+ "guix/scripts/import/pypi.scm"
+ "tests/pypi.scm")))
(define-team haskell
(team 'haskell