aboutsummaryrefslogtreecommitdiff
path: root/etc/hurd-manifest.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-02 15:04:46 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-12 23:23:33 +0100
commit12d00767f036029f1f5738de644d4972db374f4f (patch)
tree5ea390393940fde1ad29fadfb0f13a72bf32a042 /etc/hurd-manifest.scm
parentb8a45bd0473ab2ba9b96b7ef429a557ece9bf06c (diff)
downloadguix-12d00767f036029f1f5738de644d4972db374f4f.tar
guix-12d00767f036029f1f5738de644d4972db374f4f.tar.gz
etc: Move manifests to a separate directory.
* etc/disarchive-manifest.scm, etc/hurd-manifest.scm, etc/kernels-manifest.scm, etc/release-manifest.scm, etc/source-manifest.scm, etc/system-tests.scm, etc/time-travel-manifest.scm, etc/upgrade-manifest.scm: Move to… * etc/manifests: … here, and drop “-manifest” from file name. * Makefile.am (EXTRA_DIST, assert-binaries-available, check-system): Adjust accordingly. Change-Id: Iedee3d0cdd42e72ef8bbf654ea5d3b47dca95874
Diffstat (limited to 'etc/hurd-manifest.scm')
-rw-r--r--etc/hurd-manifest.scm85
1 files changed, 0 insertions, 85 deletions
diff --git a/etc/hurd-manifest.scm b/etc/hurd-manifest.scm
deleted file mode 100644
index cb6b82d5f8..0000000000
--- a/etc/hurd-manifest.scm
+++ /dev/null
@@ -1,85 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-;;; Commentary:
-;;;
-;;; This file defines a manifest with a selection of packages for Cuirass to
-;;; build for GNU/Hurd.
-;;;
-;;; Code:
-
-(use-modules (gnu)
- (gnu system hurd)
- (guix packages)
- (guix utils)
- (ice-9 match)
- (srfi srfi-1))
-
-(use-package-modules
- autotools base bootloaders commencement compression file gawk gdb gettext gtk
- guile guile-xyz hurd less m4 package-management python ssh
- texinfo tls version-control)
-
-(define (input->package input)
- "Return the INPUT as package, or #f."
- (match input
- ((label (and (? package?) package))
- package)
- ((label (and (? package?) package . output))
- (cons package output))
- (_ #f)))
-
-(define guix-dependencies
- (filter-map input->package
- (fold alist-delete (package-direct-inputs guix)
- '("glibc-utf8-locales" "graphviz" "po4a"))))
-
-(define (package-without-tests p)
- (package/inherit p
- (arguments
- (substitute-keyword-arguments (package-arguments p)
- ((#:tests? _ #f) #f)))))
-
-(packages->manifest
- (cons*
- ;; where it all starts
- hello
-
- ;; development utililities
- diffutils file findutils gawk grep gzip less m4 openssh-sans-x tar xz
-
- ;; development packages
- autoconf automake libtool texinfo
- gcc-toolchain gdb-minimal git-minimal gnu-make
- gettext-minimal python-minimal
- guile-3.0 guile-2.2 guile-2.0
- guile-readline guile-colorized
- guile-gnutls guile-fibers guile-json-4
-
- ;; ourselves!
- (package-without-tests guix)
-
- ;; system
- grub-minimal grub
-
- ;; system reconfigure
- gdk-pixbuf
-
- (append
- guix-dependencies
- %base-packages/hurd)))