aboutsummaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-04 18:26:07 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-16 00:19:56 +0100
commitf8f005815efdf9f0d5d2a5ac30c6fdd19aa22e72 (patch)
tree17a61d9b3b72ca70e39ad1d7219c9a9a2e4af955 /doc
parente9e4b2fafd77491f1865399f09f28ebe5d71916c (diff)
downloadguix-f8f005815efdf9f0d5d2a5ac30c6fdd19aa22e72.tar
guix-f8f005815efdf9f0d5d2a5ac30c6fdd19aa22e72.tar.gz
packages: Use origin file names as their input labels.
* guix/packages.scm (add-input-label): Rely on 'origin-actual-file-name' for internal inputs labels. * tests/packages.scm ("this-package-input, origin"): New test. * doc/guix.texi (package Reference): Mention origin lookup for ‘lookup-package-input’ & co. * gnu/packages/base.scm (tzdata)[inputs]: Reintroduce label. * gnu/packages/tex.scm (texlive-hyphen-complete)[inputs]: Likewise. (texlive-newverbs)[native-inputs]: Likewise. Change-Id: I6ba5352b1b1b8ab810da3730b09cb9db61d6429c Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi8
1 files changed, 6 insertions, 2 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 57030102ca..9bf177a185 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -8061,8 +8061,8 @@ inputs.
Look up @var{name} among @var{package}'s inputs (or native, propagated,
or direct inputs). Return it if found, @code{#f} otherwise.
-@var{name} is the name of a package depended on. Here's how you might
-use it:
+@var{name} is the name of a package or the file name of an origin
+depended on. Here's how you might use it:
@lisp
(use-modules (guix packages) (gnu packages base))
@@ -8073,6 +8073,10 @@ use it:
In this example we obtain the @code{gmp} package that is among the
direct inputs of @code{coreutils}.
+
+When looking up an origin, use the name that appears in the origin's
+@code{file-name} field or its default file name---e.g.,
+@code{"foo-1.2.tar.gz"}.
@end deffn
@cindex development inputs, of a package