aboutsummaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-15 21:54:34 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-16 22:50:14 +0100
commit4c0c4db0702048488a9712dbba7cad862c667d54 (patch)
tree5c809914cc75d5fc7a386f382db40253d71e959c /build-aux
parent2c715a922324e0cd1ab50c5ea0b70f12a33565d5 (diff)
downloadguix-4c0c4db0702048488a9712dbba7cad862c667d54.tar
guix-4c0c4db0702048488a9712dbba7cad862c667d54.tar.gz
utils: Move base16 procedures to (guix base16).
* guix/utils.scm (bytevector->base16-string, base16-string->bytevector): Move to... * guix/base16.scm: ... here. New file. * tests/utils.scm ("bytevector->base16-string->bytevector"): Move to... * tests/base16.scm: ... here. New file. * Makefile.am (MODULES): Add guix/base16.scm. (SCM_TESTS): Add tests/base16.scm. * build-aux/download.scm, guix/derivations.scm, guix/docker.scm, guix/import/snix.scm, guix/pk-crypto.scm, guix/scripts/authenticate.scm, guix/scripts/download.scm, guix/scripts/hash.scm, guix/store.scm, tests/hash.scm, tests/pk-crypto.scm: Adjust imports accordingly.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/download.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/build-aux/download.scm b/build-aux/download.scm
index 1e91e4b87c..8f41f33b14 100644
--- a/build-aux/download.scm
+++ b/build-aux/download.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -26,7 +26,7 @@
(web client)
(rnrs io ports)
(srfi srfi-11)
- (guix utils)
+ (guix base16)
(guix hash))
(define %url-base