aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-06-29 21:26:36 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-30 00:16:50 +0200
commit1d97fd8cb60f0b5f386f834940f859ff0b0bcc71 (patch)
tree7fc12f6d61e57a4d40f6497c644524f4357bf19b /Makefile.am
parent95bbaa02aa63bc5eae36f686f1ed9915663aa4cf (diff)
downloadguix-1d97fd8cb60f0b5f386f834940f859ff0b0bcc71.tar
guix-1d97fd8cb60f0b5f386f834940f859ff0b0bcc71.tar.gz
build: Remove check for broken (srfi srfi-37).
This was for Guile < 2.0.9 and we've been requiring 2.0.9+ for some time already. * configure.ac: Remove 'GUIX_CHECK_SRFI_37' use and 'INSTALL_SRFI_37' conditional. * Makefile.am: Remove code in "if INSTALL_SRFI_37". (EXTRA_DIST): Remove srfi/srfi-37.scm.in. * srfi/srfi-37.scm.in: Remove. * m4/guix.m4 (GUIX_CHECK_SRFI_37): Remove.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 0 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 4dfcd06d0b..8a5aa2b641 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -250,18 +250,6 @@ nobase_dist_guilemodule_DATA = \
nobase_nodist_guilemodule_DATA = guix/config.scm
nobase_nodist_guileobject_DATA = $(GOBJECTS)
-# Do we need to provide our own non-broken (srfi srfi-37) module?
-if INSTALL_SRFI_37
-
-nobase_nodist_guilemodule_DATA += srfi/srfi-37.scm
-GOBJECTS += srfi/srfi-37.go
-
-srfi/srfi-37.scm: srfi/srfi-37.scm.in
- $(MKDIR_P) srfi
- cp "$<" "$@"
-
-endif INSTALL_SRFI_37
-
# Handy way to remove the .go files without removing all the rest.
clean-go:
-$(RM) -f $(GOBJECTS)
@@ -441,7 +429,6 @@ EXTRA_DIST = \
build-aux/run-system-tests.scm \
d3.v3.js \
graph.js \
- srfi/srfi-37.scm.in \
srfi/srfi-64.scm \
srfi/srfi-64.upstream.scm \
tests/test.drv \