aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-01-12 15:35:29 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-01-20 16:16:11 +0100
commitddfcc2141ed62307b0d8aeed7456254bb48d4dd9 (patch)
tree82fdaa8fff768bf1042a9b1dd884e48fe05b407e /Makefile.am
parentb50a14422fbfbaba17fffa53c3a2b06bcecd7e99 (diff)
downloadguix-ddfcc2141ed62307b0d8aeed7456254bb48d4dd9.tar
guix-ddfcc2141ed62307b0d8aeed7456254bb48d4dd9.tar.gz
Makefile.am: Download po files from weblate.
* Makefile.am (download-po): Download from weblate.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 5dcd3c6fd3..8a8133d669 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -988,7 +988,7 @@ download-po.$(1):
fi ; \
for lang in $$$$LINGUAS; do \
if wget -nv -O "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" \
- "https://translationproject.org/latest/$(1)/$$$$lang.po" ; \
+ "https://translate.fedoraproject.org/api/translations/guix/$(1)/$$$$lang/file/" ; \
then \
mv "$(top_srcdir)/$(2)/$(3)$$$$lang.po"{.tmp,} ; \
else \
@@ -1000,11 +1000,12 @@ download-po.$(1):
endef
+$(eval $(call make-download-po-rule,documentation-cookbook,po/doc,guix-cookbook.))
+$(eval $(call make-download-po-rule,documentation-manual,po/doc,guix-manual.))
$(eval $(call make-download-po-rule,guix,po/guix))
-$(eval $(call make-download-po-rule,guix-packages,po/packages))
-$(eval $(call make-download-po-rule,guix-manual,po/doc,guix-manual.))
+$(eval $(call make-download-po-rule,packages,po/packages))
-download-po: $(foreach domain,guix guix-packages guix-manual,download-po.$(domain))
+download-po: $(foreach domain,guix packages documentation-manual documentation-cookbook,download-po.$(domain))
.PHONY: download-po
## -------------- ##