aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-07-31 16:49:29 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-09-30 10:47:59 +0200
commit313f492657f1d0863c641fa5ee7f5b7028e27c94 (patch)
tree89377c2e2bfc5d633320ce85210ecf9cc2baf281 /Makefile.am
parent10b135cef54348e48805bd9c64b463c465c65eb5 (diff)
downloadguix-313f492657f1d0863c641fa5ee7f5b7028e27c94.tar
guix-313f492657f1d0863c641fa5ee7f5b7028e27c94.tar.gz
scripts: system: Add support for image-type.
* guix/scripts/system.scm (list-image-types): New procedure, (%options): add "image-type" and "list-image-types" options, remove "file-system-type" option, (show-help): adapt accordingly, (%default-options): also adapt, and set the default "image-type" to "raw", (perform-action): add image-type argument and remove file-system-type argument, (process-action): adapt perform-action call, (system-derivation-for-action): remove base-image argument, add image-type argument, and use it to create the image passed to "system-image". * tests/guix-system.sh: Adapt accordingly and add a test for "--list-image-types" command. * doc/guix.texi (Building the Installation Image, Invoking guix system): Adapt accordingly. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e91e1e558..9c3ff4420f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -833,9 +833,8 @@ release: dist-with-updated-version
-v1 --no-grafts --fallback
for system in $(GUIX_SYSTEM_SUPPORTED_SYSTEMS) ; do \
image=`$(top_builddir)/pre-inst-env \
- guix system disk-image \
- --file-system-type=iso9660 \
- --label="GUIX_$${system}_$(VERSION)" \
+ guix system disk-image -t iso9660 \
+ --label="GUIX_$${system}_$(VERSION)" \
--system=$$system --fallback \
gnu/system/install.scm` ; \
if [ ! -f "$$image" ] ; then \