aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-07-27 12:05:14 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-27 12:06:37 +0200
commit1dba0b4557e67b32e64d98c807fb376604e5d19b (patch)
treea69aa4740a7878e9d7b2869cf632847411b5e7d3 /Makefile.am
parente095c73ea06a45619c604f715d22f15789e04a76 (diff)
downloadguix-1dba0b4557e67b32e64d98c807fb376604e5d19b.tar
guix-1dba0b4557e67b32e64d98c807fb376604e5d19b.tar.gz
maint: 'authenticate' runs the user's 'guix git authenticate'.
That way, we no longer run the code we want to authenticate. * Makefile.am (authenticate): Remove "./pre-inst-env".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 31784adfff..1e2c26f5ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -649,11 +649,10 @@ commit_v1_0_0 = 6298c3ffd9654d3231a6f25390b056483e8f407c
channel_intro_commit = 9edb3f66fd807b096b48283debdcddccfea34bad
channel_intro_signer = BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA
-# Authenticate the current Git checkout by checking signatures on every commit
-# starting from $(commit_v1_0_0).
-authenticate: guix/openpgp.go guix/git-authenticate.go guix/git.go
+# Authenticate the current Git checkout by checking signatures on every commit.
+authenticate:
$(AM_V_at)echo "Authenticating Git checkout..." ; \
- "$(top_builddir)/pre-inst-env" guix git authenticate \
+ guix git authenticate \
--cache-key=channels/guix --stats \
"$(channel_intro_commit)" "$(channel_intro_signer)"