aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-09-11 16:54:32 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-21 17:04:37 +0200
commit7e27393f82ff5e7237f870ded09652b89e457faa (patch)
tree75094685cdb252aed4a4d049f34d5ba8f582fe02
parent45201bf245856954cb8368c328e54773a0a81156 (diff)
downloadguix-7e27393f82ff5e7237f870ded09652b89e457faa.tar
guix-7e27393f82ff5e7237f870ded09652b89e457faa.tar.gz
gnu: Add r-pore.
* gnu/packages/bioinformatics.scm (r-pore): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 10330cd8b2..9599e3096f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13736,3 +13736,32 @@ juicer) and single-resolution or multi-resolution @code{.cool} files (for
cooler). Both @code{hic} and @code{cool} files describe Hi-C contact
matrices.")
(license license:expat)))
+
+(define-public r-pore
+ (package
+ (name "r-pore")
+ (version "0.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/rpore/" version
+ "/poRe_" version ".tar.gz"))
+ (sha256
+ (base32 "0pih9nljbv8g4x8rkk29i7aqq681b782r5s5ynp4nw9yzqnmmksv"))))
+ (properties `((upstream-name . "poRe")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bit64" ,r-bit64)
+ ("r-data-table" ,r-data-table)
+ ("r-rhdf5" ,r-rhdf5)
+ ("r-shiny" ,r-shiny)
+ ("r-svdialogs" ,r-svdialogs)))
+ (home-page "https://sourceforge.net/projects/rpore/")
+ (synopsis "Visualize Nanopore sequencing data")
+ (description
+ "This package provides graphical user interfaces to organize and visualize Nanopore
+sequencing data.")
+ ;; This is free software but the license variant is unclear:
+ ;; <https://github.com/mw55309/poRe_docs/issues/10>.
+ (license license:bsd-3)))