aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-21 13:29:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-21 15:03:48 +0200
commit2aa137e261984b9762de5221459835eefb165fe7 (patch)
treef67ff1bc2ff674a632fb0bfd8620bdd32a761736
parente67ad5532f76b53e955149da2f1e237696ff0893 (diff)
downloadguix-2aa137e261984b9762de5221459835eefb165fe7.tar
guix-2aa137e261984b9762de5221459835eefb165fe7.tar.gz
gnu: crossguid: Use INVOKE.
* gnu/packages/kodi.scm (crossguid)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/kodi.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index 62a971a0a8..2df5735dd0 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -92,22 +93,22 @@
(arguments
'(#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
+ (delete 'configure) ; no configure script
;; There's no build system here, so we have to do it ourselves.
(replace 'build
(lambda _
- (and (zero? (system* "g++" "-c" "guid.cpp" "-o" "guid.o"
- "-std=c++11" "-DGUID_LIBUUID"))
- (zero? (system* "ar" "rvs" "libcrossguid.a" "guid.o")))))
+ (invoke "g++" "-c" "guid.cpp" "-o" "guid.o"
+ "-std=c++11" "-DGUID_LIBUUID")
+ (invoke "ar" "rvs" "libcrossguid.a" "guid.o")))
(replace 'check
(lambda _
- (and (zero? (system* "g++" "-c" "test.cpp" "-o" "test.o"
- "-std=c++11"))
- (zero? (system* "g++" "-c" "testmain.cpp" "-o" "testmain.o"
- "-std=c++11"))
- (zero? (system* "g++" "test.o" "guid.o" "testmain.o"
- "-o" "test" "-luuid"))
- (zero? (system* (string-append (getcwd) "/test"))))))
+ (invoke "g++" "-c" "test.cpp" "-o" "test.o"
+ "-std=c++11")
+ (invoke "g++" "-c" "testmain.cpp" "-o" "testmain.o"
+ "-std=c++11")
+ (invoke "g++" "test.o" "guid.o" "testmain.o"
+ "-o" "test" "-luuid")
+ (invoke (string-append (getcwd) "/test"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))