aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-19 18:43:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-20 00:31:16 +0200
commitf19e571c970ee40902bab1fea3c8654a73caf02f (patch)
tree8031884a1e92958b80cecef47e9b3d5aab0072ea
parent28391dc038c71be4ef03c66722b09c90a75b3e55 (diff)
downloadguix-f19e571c970ee40902bab1fea3c8654a73caf02f.tar
guix-f19e571c970ee40902bab1fea3c8654a73caf02f.tar.gz
gnu: kodi: Increase test timeout.
* gnu/packages/patches/kodi-increase-test-timeout.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/kodi.scm (kodi)[source](patches): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/kodi.scm1
-rw-r--r--gnu/packages/patches/kodi-increase-test-timeout.patch18
3 files changed, 20 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 126d29dade..b4158b9880 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1017,6 +1017,7 @@ dist_patch_DATA = \
%D%/packages/patches/kobodeluxe-manpage-minus-not-hyphen.patch \
%D%/packages/patches/kobodeluxe-midicon-segmentation-fault.patch \
%D%/packages/patches/kobodeluxe-graphics-window-signed-char.patch \
+ %D%/packages/patches/kodi-increase-test-timeout.patch \
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
%D%/packages/patches/kodi-skip-test-449.patch \
%D%/packages/patches/laby-make-install.patch \
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index 0e032d05db..cba9b550d1 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -282,6 +282,7 @@ alternatives. In compilers, this can reduce the cascade of secondary errors.")
(base32
"1m0295czxabdcqyqf5m94av9d88pzhnzjvyfs1q07xqq82h313p7"))
(patches (search-patches "kodi-skip-test-449.patch"
+ "kodi-increase-test-timeout.patch"
"kodi-set-libcurl-ssl-parameters.patch"))
(snippet
'(begin
diff --git a/gnu/packages/patches/kodi-increase-test-timeout.patch b/gnu/packages/patches/kodi-increase-test-timeout.patch
new file mode 100644
index 0000000000..8fb149ff9d
--- /dev/null
+++ b/gnu/packages/patches/kodi-increase-test-timeout.patch
@@ -0,0 +1,18 @@
+Increase thread timeout to reduce flakiness.
+
+Taken from upstream:
+https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2
+
+diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp
+index 42fb8c2fc609..40e644c0ed3c 100644
+--- a/xbmc/threads/test/TestEvent.cpp
++++ b/xbmc/threads/test/TestEvent.cpp
+@@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait)
+ EXPECT_TRUE(w3.result == NULL);
+
+ // this should end given the wait is for only 50 millis
+- EXPECT_TRUE(waitThread3.timed_join(MILLIS(100)));
++ EXPECT_TRUE(waitThread3.timed_join(MILLIS(200)));
+
+ EXPECT_TRUE(!w3.waiting);
+ EXPECT_TRUE(w3.result == NULL);