aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-19 14:42:03 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-20 00:31:15 +0200
commite2ba79ef4670b548377ac0234ce7d1c294f326e9 (patch)
treec426f9e6300c3cd94e9f25c89abbfdbfea213939
parentc50b07dde89c21234807cef40ee7fd69fbfe72d7 (diff)
downloadguix-e2ba79ef4670b548377ac0234ce7d1c294f326e9.tar
guix-e2ba79ef4670b548377ac0234ce7d1c294f326e9.tar.gz
gnu: Add virtest.
* gnu/packages/check.scm (virtest): New public variable.
-rw-r--r--gnu/packages/check.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1f07cad508..b12337a135 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
@@ -2329,6 +2329,38 @@ program or test suite under a test bed with the previously recorded devices
loaded.")
(license license:lgpl2.1+)))
+(define-public virtest
+ ;; No releases yet, so we take the commit that "vc" expects.
+ (let ((commit "f7d03ef39fceba168745bd29e1b20af6e7971e04")
+ (revision "0"))
+ (package
+ (name "virtest")
+ (version (git-version "0.0" revision commit))
+ (home-page "https://github.com/mattkretz/virtest")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07pjyb0mk7y2w1dg1bhl26nb7416xa1mw16ifj6mmps5y6aq054l"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'adjust-install-directory
+ (lambda _
+ ;; Vc is the only consumer of this library, and expects
+ ;; to find it in "virtest/vir/" instead of "vir/vir/".
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION include/vir")
+ "DESTINATION include/virtest"))
+ #t)))))
+ (synopsis "Header-only test framework")
+ (description
+ "@code{virtest} is a small header-only test framework for C++. It
+grew out of the @dfn{Vc} project.")
+ (license license:bsd-3))))
+
(define-public python-pyfakefs
(package
(name "python-pyfakefs")