aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-14 13:43:20 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-10-18 18:06:38 +0300
commitdabcfc6de29032ea52d1cb54163a783f7e480167 (patch)
treebf5a12ee37e1eda701774b7103bcf8d8b7d14951
parentd8963031afa3044fe5c52d04d174a209ca6bd618 (diff)
downloadguix-dabcfc6de29032ea52d1cb54163a783f7e480167.tar
guix-dabcfc6de29032ea52d1cb54163a783f7e480167.tar.gz
gnu: Add httpie.
* gnu/packages/python-web.scm (httpie): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5c9da7c89d..752d120782 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -303,6 +304,34 @@ other HTTP libraries.")
(define-public python2-httplib2
(package-with-python2 python-httplib2))
+(define-public httpie
+ (package
+ (name "httpie")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "httpie" version))
+ (sha256
+ (base32
+ "103fcigpxf4nqmrdqjnyz7d9n4n16906slwmmqqc0gkxv8hnw6vd"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The tests attempt to access external web servers, so we cannot run them.
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-pygments" ,python-pygments)
+ ("python-requests" ,python-requests)))
+ (home-page "https://httpie.org/")
+ (synopsis "cURL-like tool for humans")
+ (description
+ "A command line HTTP client with an intuitive UI, JSON support,
+syntax highlighting, wget-like downloads, plugins, and more. It consists of
+a single http command designed for painless debugging and interaction with
+HTTP servers, RESTful APIs, and web services.")
+ (license license:bsd-3)))
+
(define-public python-html2text
(package
(name "python-html2text")